]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
aubergine: move from SD to SSD
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { lib, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
8 ];
9
10 # Setting the machine-id avoids to reencrypt all credentials
11 # when reinstalling NixOS on a new drive.
12 # Manually generated with : uuidgen | tr -d -
13 environment.etc.machine-id.source = ./machine-id.clear;
14
15 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
16 # You should try to make this id unique among your hosts.
17 # Manually generated with : uuidgen | head -c8
18 networking.hostId = "408a404a";
19
20 /*
21 boot.loader.efi = {
22 canTouchEfiVariables = true;
23 efiSysMountPoint = "/boot/efi";
24 };
25 */
26 boot.loader.grub = {
27 enable = true;
28 version = 2;
29 devices = [
30 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
31 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
32 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
33 ];
34 configurationLimit = 9;
35
36 #zfsSupport = true;
37 #efiSupport = true;
38 #enableCryptodisk = true;
39 };
40 boot.tmpOnTmpfs = true;
41
42 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
43 boot.extraModulePackages = [
44 #config.boot.kernelPackages.exfat-nofuse
45 ];
46
47 powerManagement.powertop.enable = true;
48 #services.fprintd.enable = true;
49
50 fileSystems."/" =
51 {
52 device = "${hostName}/root";
53 fsType = "zfs";
54 };
55 fileSystems."/boot" =
56 {
57 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
58 fsType = "ext4";
59 };
60 fileSystems."/boot/efi" =
61 {
62 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
63 fsType = "vfat";
64 };
65 fileSystems."/nix" =
66 {
67 device = "${hostName}/nix";
68 fsType = "zfs";
69 };
70 fileSystems."/var" =
71 {
72 device = "${hostName}/var";
73 fsType = "zfs";
74 };
75 fileSystems."/home" =
76 {
77 device = "${hostName}/home";
78 fsType = "zfs";
79 };
80 swapDevices =
81 [
82 {
83 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
84 randomEncryption = {
85 enable = true;
86 cipher = "aes-xts-plain64";
87 source = "/dev/urandom";
88 };
89 }
90 ];
91
92 hardware.pulseaudio.enable = lib.mkDefault true;
93 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
94
95 }