1 { config, lib, pkgs, hostName, ... }:
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
12 canTouchEfiVariables = true;
13 efiSysMountPoint = "/boot/efi";
20 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
21 "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
23 configurationLimit = 9;
27 #enableCryptodisk = true;
31 { device = "/dev/disk/by-partlabel/${hostName}_sd_root";
34 fileSystems."/boot/efi" =
35 { device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
40 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
43 cipher = "aes-xts-plain64";
44 source = "/dev/urandom";
50 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
51 # You should try to make this id unique among your hosts.
52 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
53 networking.hostId = "408a404a";
55 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
56 boot.extraModulePackages = [
57 #config.boot.kernelPackages.exfat-nofuse
60 powerManagement.powertop.enable = true;
61 #services.fprintd.enable = true;
65 { device = "${hostName}/root";
69 { device = "${hostName}/nix";
73 { device = "${hostName}/var";