]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
aubergine: add host
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { config, lib, pkgs, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
8 ];
9
10 /*
11 boot.loader.efi = {
12 canTouchEfiVariables = true;
13 efiSysMountPoint = "/boot/efi";
14 };
15 */
16 boot.loader.grub = {
17 enable = true;
18 version = 2;
19 devices = [
20 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
21 "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
22 ];
23 configurationLimit = 9;
24
25 #zfsSupport = true;
26 #efiSupport = true;
27 #enableCryptodisk = true;
28 };
29
30 fileSystems."/" =
31 { device = "/dev/disk/by-partlabel/${hostName}_sd_root";
32 fsType = "ext4";
33 };
34 fileSystems."/boot/efi" =
35 { device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
36 fsType = "vfat";
37 };
38 /*
39 swapDevices = [
40 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
41 randomEncryption = {
42 enable = true;
43 cipher = "aes-xts-plain64";
44 source = "/dev/urandom";
45 };
46 }
47 ];
48 */
49
50 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
51 # You should try to make this id unique among your hosts.
52 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
53 networking.hostId = "408a404a";
54
55 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
56 boot.extraModulePackages = [
57 #config.boot.kernelPackages.exfat-nofuse
58 ];
59
60 powerManagement.powertop.enable = true;
61 #services.fprintd.enable = true;
62
63 /*
64 fileSystems."/" =
65 { device = "${hostName}/root";
66 fsType = "zfs";
67 };
68 fileSystems."/nix" =
69 { device = "${hostName}/nix";
70 fsType = "zfs";
71 };
72 fileSystems."/var" =
73 { device = "${hostName}/var";
74 fsType = "zfs";
75 };
76 */
77
78 }