]> Git — Sourcephile - julm/julm-nix.git/blob - homes/programs/emacs.nix
Rename homes/{softwares => programs}
[julm/julm-nix.git] / homes / programs / emacs.nix
1 { inputs, pkgs, lib, config, ... }:
2 {
3 options = {
4 programs.doom-emacs = {
5 enable = lib.mkEnableOption "doom-emacs";
6 };
7 };
8 config = lib.mkIf config.programs.doom-emacs.enable {
9 /*
10 imports = [
11 inputs.nix-doom-emacs.hmModule
12 ];
13 programs.doom-emacs = {
14 enable = true;
15 doomPrivateDir =
16 "${config.home.homeDirectory}/.doom.d";
17 };
18 services.emacs = {
19 #enable = true; # Use with emacsclient -c
20 package = config.programs.emacs.package;
21 };
22 */
23 home.packages = with pkgs; [
24 # DOOM Emacs dependencies
25 binutils
26 (ripgrep.override { withPCRE2 = true; })
27 gnutls
28 fd
29 imagemagick
30 zstd
31 #nodePackages.javascript-typescript-langserver
32 sqlite
33 editorconfig-core-c
34 emacs
35 emacs-all-the-icons-fonts
36 ];
37 home.sessionPath = [ "${config.xdg.configHome}/emacs/bin" ];
38 home.sessionVariables = {
39 DOOMDIR = "${config.xdg.configHome}/doom-config";
40 DOOMLOCALDIR = "${config.xdg.configHome}/doom-local";
41 };
42 xdg.configFile = {
43 #"doom-config/config.el".source = emacs/config.el;
44 #"doom-config/init.el".source = emacs/init.el;
45 "doom-config/packages.el".text = "";
46 "emacs" = {
47 source = inputs.doom-emacs;
48 onChange = "${pkgs.writeShellScript "doom-change" ''
49 export DOOMDIR="${config.home.sessionVariables.DOOMDIR}"
50 export DOOMLOCALDIR="${config.home.sessionVariables.DOOMLOCALDIR}"
51 if [ ! -d "$DOOMLOCALDIR" ]; then
52 ${config.xdg.configHome}/emacs/bin/doom -y install
53 else
54 ${config.xdg.configHome}/emacs/bin/doom -y sync -u
55 fi
56 ''}";
57 };
58 };
59 };
60 }