1 { pkgs, lib, config, ... }:
4 ../../../profiles/chat.nix
5 ../../../profiles/developing.nix
6 ../../../profiles/drawing.nix
7 ../../../profiles/gaming.nix
8 ../../../profiles/graphical.nix
9 ../../../profiles/networking.nix
10 ../../../profiles/office.nix
11 ../../../profiles/security.nix
12 ../../../profiles/sharing.nix
13 ../../../profiles/system.nix
14 ../../../profiles/video.nix
15 ../../../profiles/web.nix
16 ../../../profiles/xfce.nix
18 programs.firefox.enable = false; # error: attribute 'gtk3' missing
19 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
20 programs.bash.shellAliases.firefox = "riseup firefox";
21 programs.gpg.homedir = "${config.home.homeDirectory}/documents/sec/.gnupg";
22 home.sessionVariables = {
23 PASSWORD_STORE_DIR = "$HOME/documents/sec/.password-store";
27 (pkgs.qgis.override { extraPythonPackages = (ps: [
28 ps.pyqt5_with_qtwebkit