5 enable = mkDefault true;
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 ju = "sudo journalctl --user -u";
21 ls = "ls --color=tty";
22 md-toc = "grep '^#\\+' --color";
23 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
24 mem-top = "smem --sort rss --autosize";
26 nf = "sudo nft list ruleset | less";
27 nixos-clean = "sudo nix-collect-garbage -d";
28 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
29 nixos-rollback = "sudo nixos-rebuild switch --rollback";
30 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
32 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
34 st = "sudo systemctl status";
35 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
36 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
37 u = "systemctl --user";
38 ut = "systemctl --user status";
39 w1 = "watch --color --differences --interval 1";
40 w5 = "watch --color --differences --interval 5";
41 w10 = "watch --color --differences --interval 10";
42 w = "watch --color --differences";
43 watch = "watch --color --differences";
44 zfs-umount = "zfs-unmount";
47 HISTCONTROL = "erasedups:ignorespace";
49 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
53 . ${pkgs.complete-alias}/bin/complete_alias
54 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
60 # Disable ctrl-s/ctrl-q flow control
65 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
66 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
75 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
78 find "$@" -depth -type f -print0 | sort -n -z |
79 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
80 test -e "''${0%.*}".opus ||
81 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
85 device=''${1:-/dev/sda}
86 sudo smartctl -A $device |
88 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
89 $0 ~ /Total_LBAs_Written/ {
95 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
96 printf "mean writes per hour: / %.2f", mb/poh
98 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
99 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
102 sed -e "s\$^\$$device @ \$" |
105 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
106 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
107 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
111 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
112 while IFS=: read -r file x size x
118 if test "$pid" = "$lastpid"
119 then swap=$(( swap + size ))
121 if test "$swap" -gt 0
122 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
124 if test "$pid" = self
134 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
135 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
137 # Recursively mount not-mounted dataset,
138 # loading their keys if needed.
140 for d in $(zfs list -rH -o name "$@"); do
141 mountpoint /mnt/"$d" 2>/dev/null ||
142 sudo zfs mount -l "$d"
145 # Recursively unmount dataset,
146 # unloading their keys.
147 zfs-unmount () { sudo zfs unmount -u "$@"; }
149 # Restore the inheritance of encryptionroot,
150 # usually broken by zfs send --raw.
151 # Note that it needs to decrypt the datasets.
152 zfs-fix-encryptionroot () {
154 for i in $(zfs list -rHo name "$1" | tail -n +2); do
156 test "$(zfs get -Ho value encryptionroot $i)" = "$1" ||
157 zfs change-key -li "$i"
164 programs.direnv.enableBashIntegration = true;
165 #programs.broot.enableBashIntegration = true;
166 programs.readline = {
167 enable = mkDefault true;
168 includeSystemConfig = true;
171 "\\e[A" = "history-search-backward";
172 "\\e[B" = "history-search-forward";
174 # Ctrl-Left/Ctrl-Right
175 "\\e[1;5C" = "forward-word";
176 "\\e[1;5D" = "backward-word";
177 "\\e[5C" = "forward-word";
178 "\\e[5D" = "backward-word";
179 "\\e\\e[C" = "forward-word";
180 "\\e\\e[D" = "backward-word";
183 "\\e[1~" = "beginning-of-line";
184 "\\e[4~" = "end-of-line";
187 "\\e[3~" = "delete-char";
188 "\\e[2~" = "quoted-insert";
190 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
191 "\\eOF" = "end-of-line";
192 "\\eOH" = "beginning-of-line";
194 # For freebsd console
195 "\\e[F" = "end-of-line";
196 "\\e[H" = "beginning-of-line";
199 "\\e[7~" = "beginning-of-line";
200 "\\e[8~" = "end-of-line";
201 "\\eOc" = "forward-word";
202 "\\eOd" = "backward-word";
207 input-meta = mkDefault true;
208 output-meta = mkDefault true;
209 colored-completion-prefix = mkDefault true;
210 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
211 echo-control-characters = mkDefault true;
212 mark-symlinked-directories = mkDefault true;
213 menu-complete-display-prefix = mkDefault true;
214 show-all-if-ambiguous = mkDefault true;
215 show-all-if-unmodified = mkDefault true;
216 visible-stats = mkDefault false; # Append char to indicate type
217 enable-bracketed-paste = mkDefault true;