]> Git — Sourcephile - julm/julm-nix.git/blob - shell.nix
shell: add gnupg
[julm/julm-nix.git] / shell.nix
1 { pkgs, inputs, system, nixpkgsPath, shellHook ? "", ... }:
2 pkgs.mkShell {
3 name = "shell";
4 src = null;
5 #preferLocalBuild = true;
6 #allowSubstitutes = false;
7 buildInputs = [
8 (pkgs.nixos [ ]).nixos-install
9 pkgs.gnumake
10 pkgs.gptfdisk
11 pkgs.gnupg
12 pkgs.pinentry-curses
13 ];
14 #enableParallelBuilding = true;
15 NIX_PATH = pkgs.lib.concatStringsSep ":" [
16 "nixpkgs=${nixpkgsPath}"
17 "nixpkgs-overlays=${inputs.self}/nixpkgs/overlays.nix"
18 "home-manager=${inputs.home-manager}"
19 ];
20 shellHook = ''
21 echo >&2 "nix: running shellHook"
22 PATH="${inputs.home-manager.defaultPackage.${system}}/bin:$PATH"
23 PASSWORD_STORE_DIR=$PWD
24 nix-store --add-root nixpkgs.root --indirect --realise ${nixpkgsPath}
25 ${shellHook}
26 '';
27 }