]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/yt-dlp.nix
yt-dlp: fix deprecated --all-subs
[julm/julm-nix.git] / home-manager / profiles / yt-dlp.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ./aria2c.nix
5 ];
6 home.packages = [
7 # error: phantomjs 1.9.8 has been dropped due to lack of maintenance and security issues
8 #pkgs.phantomjs
9 pkgs.yt-dlp
10 ];
11 xdg.configFile."yt-dlp/config".text = ''
12 #--download-archive .downloaded
13 --embed-chapters
14 --embed-subs
15 --sub-langs all --write-subs
16 --format ${lib.concatStringsSep "/" [
17 #"bestvideo[height=360][ext=mp4]+bestaudio"
18 "bestvideo[height=480][ext=mp4]+bestaudio"
19 #"best[height=360][ext=mp4]"
20 "best[height=480][ext=mp4]"
21 #"best[height=360]"
22 "best[height=480]"
23 "best"
24 ]}
25 --output "%(upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
26 --prefer-free-formats
27 --sub-format ass/srt/best
28 --user-agent Mozilla/5.0
29 '';
30 }