]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
nix: update inputs
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { lib, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
8 ];
9
10 # Setting the machine-id avoids to reencrypt all credentials
11 # when reinstalling NixOS on a new drive.
12 # Manually generated with : uuidgen | tr -d -
13 environment.etc.machine-id.source = ./machine-id.clear;
14
15 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
16 # You should try to make this id unique among your hosts.
17 # Manually generated with : uuidgen | head -c8
18 networking.hostId = "408a404a";
19
20 /*
21 boot.loader.efi = {
22 canTouchEfiVariables = true;
23 efiSysMountPoint = "/boot/efi";
24 };
25 */
26 boot.loader.grub = {
27 enable = true;
28 devices = [
29 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
30 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
31 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
32 ];
33 configurationLimit = 9;
34
35 #zfsSupport = true;
36 #efiSupport = true;
37 #enableCryptodisk = true;
38 };
39 boot.tmp.useTmpfs = true;
40
41 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
42 boot.extraModulePackages = [
43 #config.boot.kernelPackages.exfat-nofuse
44 ];
45
46 powerManagement.powertop.enable = true;
47 #services.fprintd.enable = true;
48
49 fileSystems."/" =
50 {
51 device = "${hostName}/root";
52 fsType = "zfs";
53 };
54 fileSystems."/boot" =
55 {
56 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
57 fsType = "ext4";
58 };
59 fileSystems."/boot/efi" =
60 {
61 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
62 fsType = "vfat";
63 };
64 fileSystems."/nix" =
65 {
66 device = "${hostName}/nix";
67 fsType = "zfs";
68 };
69 fileSystems."/var" =
70 {
71 device = "${hostName}/var";
72 fsType = "zfs";
73 };
74 fileSystems."/home" =
75 {
76 device = "${hostName}/home";
77 fsType = "zfs";
78 };
79 swapDevices =
80 [
81 {
82 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
83 randomEncryption = {
84 enable = true;
85 cipher = "aes-xts-plain64";
86 source = "/dev/urandom";
87 };
88 }
89 ];
90
91 hardware.pulseaudio.enable = lib.mkDefault true;
92 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
93
94 }