]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/oignon/hardware.nix
nix: update inputs
[julm/julm-nix.git] / hosts / oignon / hardware.nix
1 { pkgs, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/X201.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
7 ];
8
9 # Setting the machine-id avoids to reencrypt all credentials
10 # when reinstalling NixOS on a new drive.
11 # Manually generated with : uuidgen | tr -d -
12 environment.etc.machine-id.source = ./machine-id.clear;
13
14 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
15 # You should try to make this id unique among your hosts.
16 # Manually generated with : uuidgen | head -c8
17 networking.hostId = "ce53d0c3";
18
19 /*
20 boot.loader.efi = {
21 canTouchEfiVariables = true;
22 efiSysMountPoint = "/boot/efi";
23 };
24 */
25 boot.loader.grub = {
26 enable = true;
27 memtest86.enable = true;
28 devices = [
29 "/dev/disk/by-id/ata-Samsung_SSD_850_PRO_128GB_S1SMNSAFC36436X"
30 ];
31 configurationLimit = 16;
32
33 #zfsSupport = true;
34 #efiSupport = true;
35 #enableCryptodisk = true;
36 };
37
38 # Note that gobi_loader -2000 has to be rerun if the SIM is hot swapped
39 services.udev.extraRules = ''
40 ACTION=="add", SUBSYSTEM=="tty", KERNEL=="ttyUSB*", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", RUN+="${pkgs.gobi_loader}/lib/udev/gobi_loader -2000 $env{DEVNAME} /home/julm/documents/thinkpad-x201/gobi"
41 '';
42
43 fileSystems."/boot" =
44 {
45 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
46 fsType = "ext2";
47 };
48 fileSystems."/boot/efi" =
49 {
50 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
51 fsType = "vfat";
52 };
53 swapDevices = [
54 {
55 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
56 randomEncryption = {
57 enable = true;
58 cipher = "aes-xts-plain64";
59 source = "/dev/urandom";
60 };
61 }
62 ];
63
64 boot.supportedFilesystems = [ "ntfs" "vfat" ];
65
66 fileSystems."/" =
67 {
68 device = "${hostName}/root";
69 fsType = "zfs";
70 };
71 fileSystems."/nix" =
72 {
73 device = "${hostName}/nix";
74 fsType = "zfs";
75 };
76 fileSystems."/var" =
77 {
78 device = "${hostName}/var";
79 fsType = "zfs";
80 };
81
82 services.pipewire.jack.enable = true;
83
84 }