]> Git — Sourcephile - julm/julm-nix.git/blob - shell.nix
systemd-creds: move to creds-{setup,encrypt,decrypt}.sh
[julm/julm-nix.git] / shell.nix
1 { pkgs, inputs, system, ... }:
2 pkgs.mkShell {
3 name = "shell";
4 src = null;
5 #preferLocalBuild = true;
6 #allowSubstitutes = false;
7 buildInputs = [
8 (pkgs.nixos []).nixos-install
9 ];
10 #enableParallelBuilding = true;
11 NIX_PATH = pkgs.lib.concatStringsSep ":" [
12 "nixpkgs=${inputs.nixpkgs}"
13 "nixpkgs-overlays=${inputs.self}/nixpkgs/overlays.nix"
14 "home-manager=${inputs.home-manager}"
15 ];
16 shellHook = ''
17 echo >&2 "nix: running shellHook"
18 PATH="${inputs.home-manager.defaultPackage.${system}}/bin:$PATH"
19 PASSWORD_STORE_DIR=$PWD
20 '';
21 }