]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/networking/ssh.nix
ssh: avoid restart by not using inputs.self
[julm/julm-nix.git] / nixos / profiles / networking / ssh.nix
1 { lib, inputs, hostName, ... }:
2 with lib;
3 {
4 programs.mosh.enable = mkDefault true;
5 services.openssh.enable = true;
6 # TODO: use hostKeys= once LoadCredentialEncrypted= works in ExecStartPre=
7 services.openssh.hostKeys = mkForce [ ];
8 services.openssh.extraConfig = ''
9 HostKey /run/credentials/sshd.service/host.key
10 '';
11 }