5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
12 d = "sudo resolvectl";
13 dust = "dust --bars-on-right --full-paths";
14 emacs = "emacsclient --create-frame";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 jf = "sudo journalctl -f -u";
19 jf200 = "sudo journalctl -f -n 200 -u";
20 jftoday = "sudo journalctl -f --since today -u";
21 ju = "journalctl --user -u";
24 ls = "ls --color=tty";
25 lst = "ls --sort=time --reverse -1";
26 md-toc = "grep '^#\\+' --color";
27 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
28 mem-top = "smem --sort rss --autosize";
30 n = "sudo networkctl";
31 nf = "sudo nft list ruleset | less";
32 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
33 nixos-clean = "sudo nix-collect-garbage -d";
34 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
35 nixos-rollback = "sudo nixos-rebuild switch --rollback";
36 nt = "sudo networkctl status";
37 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
39 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
40 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
41 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
43 sr = "sudo systemctl restart";
44 ssh-unknown = "ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null";
45 st = "sudo systemctl status";
46 smt-on = "echo on | sudo tee /sys/devices/system/cpu/smt/control";
47 smt-off = "echo off | sudo tee /sys/devices/system/cpu/smt/control";
52 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
53 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
54 u = "systemctl --user";
56 ur = "systemctl --user restart";
57 ut = "systemctl --user status";
58 w = "watch --color --differences";
59 w1 = "watch --color --differences --interval 1";
60 w10 = "watch --color --differences --interval 10";
61 w5 = "watch --color --differences --interval 5";
62 watch = "watch --color --differences";
64 ze = "sudo zpool export";
65 zfs-umount = "zfs-unmount";
66 zi = "sudo zpool import";
68 zlb = "zfs list -t bookmarks";
69 zls = "zfs list -t snap";
73 zs5 = "w5 zpool status";
86 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
87 # More throughput than chacha20-poly1305@openssh.com
88 # on hardware with AES acceleration.
89 RSYNC_RSH = "ssh -c aes128-gcm@openssh.com,chacha20-poly1305@openssh.com";
93 . ${pkgs.complete-alias}/bin/complete_alias
94 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
100 # Disable ctrl-s/ctrl-q flow control
105 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
110 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
114 find "$@" -depth -type f -print0 | sort -n -z |
115 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
116 test -e "''${0%.*}".opus ||
117 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
122 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
123 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
132 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
135 device=''${1:-/dev/sda}
136 sudo smartctl -A $device |
138 $0 ~ /Power_On_Hours/ {
140 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
142 $0 ~ /Total_LBAs_Written/ {
148 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
149 printf "mean writes per hour / %.2f", mb/poh
151 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
152 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
153 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
156 sed -e "s\$^\$$device @ \$" |
159 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
160 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
161 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
165 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
166 while IFS=: read -r file x size x
172 if test "$pid" = "$lastpid"
173 then swap=$(( swap + size ))
175 if test "$swap" -gt 0
176 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
178 if test "$pid" = self
189 # Recursively mount not-mounted dataset,
190 # loading their keys if needed.
194 for d in $(zfs list -rH -o name "$@"); do
195 mountpoint /mnt/"$d" 2>/dev/null ||
196 sudo zfs mount -l "$d"
200 # Recursively unmount dataset,
201 # unloading their keys.
202 zfs-unmount () { sudo zfs unmount -u "$@"; }
204 # Create bookmarks for all the snapshots of the given datasets.
205 # Bookmarks are only useful on source datasets
206 # But syncoid --create-bookmark only creates
207 # a bookmark for the latest snapshot,
208 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
209 zfs-fix-bookmarks () {
214 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
215 sudo zfs bookmark "$s" "''${s//@/#}"
220 # Restore the inheritance of encryptionroot,
221 # usually broken by zfs send --raw.
222 # Note that it needs to decrypt the datasets.
223 zfs-fix-encryptionroot () {
226 for d in $(zfs list -rHo name "$1" | tail -n +2); do
228 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
229 sudo zfs change-key -li "$d"
233 # Recursively remove all the snapshots of given datasets
234 zfs-destroy-snapshots () {
237 zfs list -t snapshot -rHo name "$d" |
238 sudo xargs --no-run-if-empty -L1 zfs destroy
244 #programs.broot.enableBashIntegration = true;
245 programs.readline = {
246 enable = mkDefault true;
247 includeSystemConfig = true;
250 "\\e[A" = "history-search-backward";
251 "\\e[B" = "history-search-forward";
252 "\\eOA" = "history-search-backward";
253 "\\eOB" = "history-search-forward";
255 # Ctrl-Left/Ctrl-Right
256 "\\e[1;5C" = "forward-word";
257 "\\e[1;5D" = "backward-word";
258 "\\e[5C" = "forward-word";
259 "\\e[5D" = "backward-word";
260 "\\e\\e[C" = "forward-word";
261 "\\e\\e[D" = "backward-word";
264 "\\e[1~" = "beginning-of-line";
265 "\\e[4~" = "end-of-line";
268 "\\e[3~" = "delete-char";
269 "\\e[2~" = "quoted-insert";
271 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
272 "\\eOF" = "end-of-line";
273 "\\eOH" = "beginning-of-line";
275 # For freebsd console
276 "\\e[F" = "end-of-line";
277 "\\e[H" = "beginning-of-line";
280 "\\e[7~" = "beginning-of-line";
281 "\\e[8~" = "end-of-line";
282 "\\eOc" = "forward-word";
283 "\\eOd" = "backward-word";
288 input-meta = mkDefault true;
289 output-meta = mkDefault true;
290 colored-completion-prefix = mkDefault true;
291 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
292 echo-control-characters = mkDefault true;
293 mark-symlinked-directories = mkDefault true;
294 menu-complete-display-prefix = mkDefault true;
295 show-all-if-ambiguous = mkDefault true;
296 show-all-if-unmodified = mkDefault true;
297 visible-stats = mkDefault false; # Append char to indicate type
298 enable-bracketed-paste = mkDefault true;