9 ../../nixos/profiles/hardware/apu6b4.nix
10 ../../nixos/profiles/hardware/ME909u-521.nix
11 ../../nixos/profiles/serial.nix
12 ../../nixos/profiles/zfs.nix
13 ../../nixos/profiles/zramSwap.nix
14 ../../nixos/profiles/pipewire.nix
17 # Setting the machine-id avoids to reencrypt all credentials
18 # when reinstalling NixOS on a new drive.
19 # Manually generated with : uuidgen | tr -d -
20 environment.etc.machine-id.source = ./machine-id.clear;
22 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
23 # You should try to make this id unique among your hosts.
24 # Manually generated with : uuidgen | head -c8
25 networking.hostId = "408a404a";
29 canTouchEfiVariables = true;
30 efiSysMountPoint = "/boot/efi";
36 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
37 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
38 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
40 configurationLimit = 9;
44 #enableCryptodisk = true;
47 boot.supportedFilesystems = [
51 boot.extraModulePackages = [
52 #config.boot.kernelPackages.exfat-nofuse
54 boot.zfs.requestEncryptionCredentials = [ hostName ];
56 hardware.enableRedistributableFirmware = true;
58 powerManagement.powertop.enable = true;
60 #services.fprintd.enable = true;
63 device = "${hostName}/root";
66 fileSystems."/boot" = {
67 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
70 fileSystems."/boot/efi" = {
71 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
74 fileSystems."/nix" = {
75 device = "${hostName}/nix";
78 fileSystems."/var" = {
79 device = "${hostName}/var";
82 fileSystems."/home" = {
83 device = "${hostName}/home";
88 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
91 cipher = "aes-xts-plain64";
92 source = "/dev/urandom";