]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/courge/backup.nix
nix: format with nixfmt-rfc-style
[julm/julm-nix.git] / hosts / courge / backup.nix
1 {
2 pkgs,
3 lib,
4 hostName,
5 ...
6 }:
7 with builtins;
8 {
9 services.sanoid = {
10 enable = true;
11 extraArgs = [ "--verbose" ];
12 datasets = {
13 "${hostName}/root/home/mo" = {
14 autosnap = true;
15 autoprune = true;
16 hourly = 0;
17 daily = 15;
18 monthly = 0;
19 yearly = 0;
20 recursive = true;
21 };
22 "${hostName}/root/home/mo/.cache" = {
23 autosnap = false;
24 };
25 "${hostName}/root/home/mo/.mozilla" = {
26 autosnap = true;
27 autoprune = true;
28 daily = 3;
29 };
30 "${hostName}/root/home/mo/.thunderbird" = {
31 autosnap = true;
32 autoprune = true;
33 hourly = 12;
34 daily = 7;
35 };
36 "${hostName}/root/home/mo/Documents" = {
37 autosnap = true;
38 autoprune = true;
39 hourly = 12;
40 daily = 31;
41 };
42 "${hostName}/root/home/mo/Telechargements" = {
43 autosnap = false;
44 };
45 };
46 };
47 }