]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/minimal.nix
nix: format with nixfmt-rfc-style
[julm/julm-nix.git] / hosts / minimal.nix
1 # Usage:
2 # nix -L build .#nixosConfigurations.minimal.config.system.build.isoImage
3 # sudo dd if=result/iso/nixos-24.11-patch-75f694f-x86_64-linux.iso of=/dev/disk/by-id/usb-Generic_Mass-Storage-0\:0 status=progress bs=4M
4 # sync
5 {
6 pkgs,
7 lib,
8 config,
9 inputs,
10 hosts,
11 modulesPath,
12 ...
13 }:
14 {
15 imports = [
16 (modulesPath + "/installer/cd-dvd/installation-cd-minimal.nix")
17 ];
18
19 # Lower kernel's security for better performances
20 security.kernel.mitigations = "off";
21
22 nixpkgs.hostPlatform = {
23 system = "x86_64-linux";
24 config = "x86_64-unknown-linux-gnu";
25 };
26
27 ## Some useful options for setting up a new system
28 services.getty.autologinUser = lib.mkForce "root";
29 users.users.root.openssh.authorizedKeys.keys =
30 hosts.blackberry.config.users.users.julm.openssh.authorizedKeys.keys;
31 #console.keyMap = "de";
32 # hardware.video.hidpi.enable = true;
33
34 # Faster
35 isoImage.squashfsCompression = lib.mkDefault "gzip -Xcompression-level 1";
36
37 system.stateVersion = config.system.nixos.release;
38
39 documentation = {
40 enable = false;
41 doc.enable = false;
42 };
43
44 }