]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/networking/ssh.nix
nix: format with nixfmt-rfc-style
[julm/julm-nix.git] / nixos / profiles / networking / ssh.nix
1 {
2 lib,
3 inputs,
4 hostName,
5 ...
6 }:
7 with lib;
8 {
9 programs.mosh.enable = mkDefault true;
10 services.openssh.enable = true;
11 # TODO: use hostKeys= once LoadCredentialEncrypted= works in ExecStartPre=
12 services.openssh.hostKeys = mkForce [ ];
13 services.openssh.extraConfig = ''
14 HostKey /run/credentials/sshd.service/host.key
15 '';
16 }