]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/networking/nftables.nix
nftables: revamp using nested declarations
[julm/julm-nix.git] / hosts / aubergine / networking / nftables.nix
1 { pkgs, lib, config, hosts, ... }:
2 let
3 inherit (config.users) users;
4 in
5 {
6 networking.firewall.enable = false;
7 security.lockKernelModules = false;
8 systemd.services.disable-kernel-module-loading.after = [ "nftables.service" ];
9 # echo -e "$(nix eval hosts.aubergine.config.networking.nftables.ruleset)"
10 # nft list ruleset
11 networking.nftables = {
12 enable = true;
13 ruleset = ''
14 table inet filter {
15 chain input-lan {
16 meta l4proto { udp, tcp } th dport domain counter accept comment "DNS"
17 meta l4proto { udp, tcp } th dport bootps counter accept comment "DHCP"
18 tcp dport ssh counter accept comment "SSH"
19 udp dport 60000-61000 counter accept comment "Mosh"
20 }
21 chain input-net {
22 jump check-public
23 }
24 chain input-intra {
25 tcp dport ssh counter accept comment "SSH"
26 udp dport 60000-61000 counter accept comment "Mosh"
27 }
28
29 chain output-lan {
30 tcp dport { ssh, 2222 } counter accept comment "SSH"
31 counter accept
32 }
33 chain output-net {
34 tcp dport { ssh, 2222 } counter accept comment "SSH"
35 udp dport 60000-61000 counter accept comment "Mosh"
36 tcp dport { http, https } counter accept comment "HTTP"
37 udp dport ntp skuid ${users.systemd-timesync.name} counter accept comment "NTP"
38 meta l4proto { udp, tcp } skuid dnscrypt-proxy2 counter accept comment "dnscrypt-proxy2"
39 tcp dport git counter accept comment "Git"
40 }
41 chain output-intra {
42 tcp dport { ssh, 2222 } counter accept comment "SSH"
43 udp dport 60001-60010 counter accept comment "Mosh"
44 tcp dport { http, https } counter accept comment "HTTP"
45 tcp dport git counter accept comment "Git"
46 }
47 }
48 '';
49 };
50 }