3 interactiveShellInit = ''
4 bind '"\e[A":history-search-backward'
5 bind '"\e[B":history-search-forward'
7 # Ignore duplicate commands, ignore commands starting with a space
8 export HISTCONTROL=erasedups:ignorespace
10 # Append to the history instead of overwriting (good for multiple connections)
14 mkcd () { mkdir -p "$1"; cd "$1"; }
18 grep = "grep --color";
21 ls = "ls --color=tty";
22 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
25 st="sudo systemctl status";
26 j="sudo journalctl -u";
27 jb="sudo journalctl -b";
29 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";