5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
12 dust = "dust --bars-on-right --full-paths";
13 emacs = "emacsclient --create-frame";
14 grep = "grep --color";
15 j = "sudo journalctl -u";
16 jb = "sudo journalctl -b";
17 ju = "sudo journalctl --user -u";
20 ls = "ls --color=tty";
21 md-toc = "grep '^#\\+' --color";
22 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
23 mem-top = "smem --sort rss --autosize";
25 n = "sudo networkctl";
26 nf = "sudo nft list ruleset | less";
27 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
28 nixos-clean = "sudo nix-collect-garbage -d";
29 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
30 nixos-rollback = "sudo nixos-rebuild switch --rollback";
31 nt = "sudo networkctl status";
32 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
34 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
35 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
36 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
38 sr = "sudo systemctl restart";
39 ssh-unknown = "ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null";
40 st = "sudo systemctl status";
45 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
46 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
47 u = "systemctl --user";
48 ur = "systemctl --user restart";
49 ut = "systemctl --user status";
50 w = "watch --color --differences";
51 w1 = "watch --color --differences --interval 1";
52 w10 = "watch --color --differences --interval 10";
53 w5 = "watch --color --differences --interval 5";
54 watch = "watch --color --differences";
56 ze = "sudo zpool export";
57 zfs-umount = "zfs-unmount";
58 zi = "sudo zpool import";
60 zlb = "zfs list -t bookmarks";
61 zls = "zfs list -t snap";
65 zs5 = "w5 zpool status";
68 historyControl = [ "erasedups" "ignorespace" ];
75 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
76 # More throughput than chacha20-poly1305@openssh.com
77 # on hardware with AES acceleration.
78 RSYNC_RSH = "ssh -c aes128-gcm@openssh.com,chacha20-poly1305@openssh.com";
82 . ${pkgs.complete-alias}/bin/complete_alias
83 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
89 # Disable ctrl-s/ctrl-q flow control
94 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
99 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
103 find "$@" -depth -type f -print0 | sort -n -z |
104 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
105 test -e "''${0%.*}".opus ||
106 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
111 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
112 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
121 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
124 device=''${1:-/dev/sda}
125 sudo smartctl -A $device |
127 $0 ~ /Power_On_Hours/ {
129 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
131 $0 ~ /Total_LBAs_Written/ {
137 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
138 printf "mean writes per hour / %.2f", mb/poh
140 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
141 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
142 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
145 sed -e "s\$^\$$device @ \$" |
148 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
149 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
150 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
154 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
155 while IFS=: read -r file x size x
161 if test "$pid" = "$lastpid"
162 then swap=$(( swap + size ))
164 if test "$swap" -gt 0
165 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
167 if test "$pid" = self
178 # Recursively mount not-mounted dataset,
179 # loading their keys if needed.
183 for d in $(zfs list -rH -o name "$@"); do
184 mountpoint /mnt/"$d" 2>/dev/null ||
185 sudo zfs mount -l "$d"
189 # Recursively unmount dataset,
190 # unloading their keys.
191 zfs-unmount () { sudo zfs unmount -u "$@"; }
193 # Create bookmarks for all the snapshots of the given datasets.
194 # Bookmarks are only useful on source datasets
195 # But syncoid --create-bookmark only creates
196 # a bookmark for the latest snapshot,
197 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
198 zfs-fix-bookmarks () {
203 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
204 zfs bookmark "$s" "''${s//@/#}"
209 # Restore the inheritance of encryptionroot,
210 # usually broken by zfs send --raw.
211 # Note that it needs to decrypt the datasets.
212 zfs-fix-encryptionroot () {
215 for d in $(zfs list -rHo name "$1" | tail -n +2); do
217 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
218 zfs change-key -li "$d"
222 # Recursively remove all the snapshots of given datasets
223 zfs-destroy-snapshots () {
226 zfs list -t snapshot -rHo name "$d" |
227 xargs --no-run-if-empty -L1 zfs destroy
234 #programs.broot.enableBashIntegration = true;
235 programs.readline = {
236 enable = mkDefault true;
237 includeSystemConfig = true;
240 "\\e[A" = "history-search-backward";
241 "\\e[B" = "history-search-forward";
242 "\\eOA" = "history-search-backward";
243 "\\eOB" = "history-search-forward";
245 # Ctrl-Left/Ctrl-Right
246 "\\e[1;5C" = "forward-word";
247 "\\e[1;5D" = "backward-word";
248 "\\e[5C" = "forward-word";
249 "\\e[5D" = "backward-word";
250 "\\e\\e[C" = "forward-word";
251 "\\e\\e[D" = "backward-word";
254 "\\e[1~" = "beginning-of-line";
255 "\\e[4~" = "end-of-line";
258 "\\e[3~" = "delete-char";
259 "\\e[2~" = "quoted-insert";
261 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
262 "\\eOF" = "end-of-line";
263 "\\eOH" = "beginning-of-line";
265 # For freebsd console
266 "\\e[F" = "end-of-line";
267 "\\e[H" = "beginning-of-line";
270 "\\e[7~" = "beginning-of-line";
271 "\\e[8~" = "end-of-line";
272 "\\eOc" = "forward-word";
273 "\\eOd" = "backward-word";
278 input-meta = mkDefault true;
279 output-meta = mkDefault true;
280 colored-completion-prefix = mkDefault true;
281 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
282 echo-control-characters = mkDefault true;
283 mark-symlinked-directories = mkDefault true;
284 menu-complete-display-prefix = mkDefault true;
285 show-all-if-ambiguous = mkDefault true;
286 show-all-if-unmodified = mkDefault true;
287 visible-stats = mkDefault false; # Append char to indicate type
288 enable-bracketed-paste = mkDefault true;