1 { pkgs, lib, config, ... }:
8 config.host.name == "patate";
9 programs.bash.enable = true;
10 programs.git.enable = true;
11 programs.git.package = pkgs.gitMinimal;
12 programs.gpg.enable = true;
13 programs.htop.enable = true;
14 programs.home-manager.enable = true;
15 programs.ssh.enable = true;
16 programs.vim.enable = true;
17 home.file.".profile".text = ''
18 # Tell XFCE to not start ssh-agent
19 if command -v xfconf-query >/dev/null && test ''${DISPLAY:+set}; then
20 xfconf-query -c xfce4-session -p /startup/ssh-agent/enabled -n -t bool -s false
23 services.gpg-agent.enable = true;
24 services.redshift.enable = config.host.desktop;
25 home.sessionVariables = {
29 LOCALE_ARCHIVE = "${pkgs.glibcLocales}/lib/locale/locale-archive";
31 PATH = lib.makeBinPath [ config.home.homeDirectory ] + ":$PATH";
53 #pkgs.haskell.packages.ghc865.zerobin
56 pkgs.hunspellDicts.fr-moderne
61 pkgs.linuxPackages.cpupower
89 ] ++ lib.optionals config.host.desktop [
106 pkgs.networkmanager-openvpn
107 pkgs.networkmanagerapplet
112 pkgs.transmission-gtk
118 pkgs.elementary-xfce-icon-theme
119 pkgs.gnome3.gnome-calculator
120 pkgs.gnome3.defaultIconTheme
121 pkgs.gnome3.file-roller
122 pkgs.gnome3.gnome-keyring
124 pkgs.hicolor-icon-theme
125 pkgs.xfce.thunar-volman