]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/yt-dlp.nix
phantomjs: no longer packaged
[julm/julm-nix.git] / home-manager / profiles / yt-dlp.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ./aria2c.nix
5 ];
6 home.packages = [
7 # error: phantomjs 1.9.8 has been dropped due to lack of maintenance and security issues
8 #pkgs.phantomjs
9 pkgs.yt-dlp
10 ];
11 xdg.configFile."yt-dlp/config".text = ''
12 #--download-archive .downloaded
13 --embed-subs
14 --format ${lib.concatStringsSep "/" [
15 #"bestvideo[height=360][ext=mp4]+bestaudio"
16 "bestvideo[height=480][ext=mp4]+bestaudio"
17 #"best[height=360][ext=mp4]"
18 "best[height=480][ext=mp4]"
19 #"best[height=360]"
20 "best[height=480]"
21 "best"
22 ]}
23 --output "%(upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
24 --prefer-free-formats
25 '';
26 }