]> Git — Sourcephile - julm/julm-nix.git/blob - homes.nix
fix packages
[julm/julm-nix.git] / homes.nix
1 # This file is only used when home-manager
2 # is called manually, not when integrated into NixOS.
3 with builtins;
4 { pkgs, lib, config, ... }:
5 {
6 nixpkgs.overlays = import <nixpkgs-overlays>;
7 imports = [
8 (./homes + "/julm.nix")
9 homes/softwares.nix
10 #homes/options.nix
11 ];
12 config = {
13 home.stateVersion = lib.mkDefault "20.09";
14 home.username = lib.mkDefault (getEnv "USER");
15 home.homeDirectory = lib.mkDefault "/home/${config.home.username}";
16 #programs.home-manager.enable = false; # Installed by NixOS
17 };
18 }