]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/oignon/tor.nix
nix: downgrade to 20.09 to benefit from the binary cache
[julm/julm-nix.git] / hosts / oignon / tor.nix
1 { pkgs, lib, config, ... }:
2 {
3 environment.systemPackages = [
4 pkgs.nyx
5 ];
6 services.tor = {
7 enable = true;
8 enableGeoIP = true;
9 controlSocket.enable = true;
10 client.enable = true;
11 # FIXME: remove when updating to 21.05
12 client.privoxy.enable = true;
13 };
14 services.privoxy.enable = true;
15 # FIXME: uncomment when updating to 21.05
16 #services.privoxy.enableTor = true;
17 }