1 { config, lib, pkgs, hostName, ... }:
4 ../../nixos/profiles/acpid.nix
5 ../../nixos/profiles/hardware/thinkpad.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
12 canTouchEfiVariables = true;
13 efiSysMountPoint = "/boot/efi";
20 "/dev/disk/by-id/ata-Samsung_SSD_850_PRO_128GB_S1SMNSAFC36436X"
22 configurationLimit = 16;
26 #enableCryptodisk = true;
29 services.udev.extraRules = ''
30 ACTION=="add", SUBSYSTEM=="tty", KERNEL=="ttyUSB*", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", RUN+="${pkgs.gobi_loader}/lib/udev/gobi_loader -2000 $env{DEVNAME} /home/julm/documents/thinkpad-x201/gobi"
35 { device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
38 fileSystems."/boot/efi" =
39 { device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
43 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
46 cipher = "aes-xts-plain64";
47 source = "/dev/urandom";
52 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
53 # You should try to make this id unique among your hosts.
54 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
55 networking.hostId = "ce53d0c3";
57 boot.supportedFilesystems = [ "ntfs" "vfat" ];
58 boot.extraModulePackages = [
59 #config.boot.kernelPackages.exfat-nofuse
62 powerManagement.powertop.enable = true;
63 #services.fprintd.enable = true;
66 { device = "${hostName}/root";
70 { device = "${hostName}/nix";
74 { device = "${hostName}/var";