]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add ffmpeg-{opus,audio}
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 shellAliases = {
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
8 c = "bat";
9 cl = "clear";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
13 g = "git";
14 gg = "git grep";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 ju = "sudo journalctl --user -u";
19 l = "ls -alh";
20 ll = "ls -al";
21 ls = "ls --color=tty";
22 md-toc = "grep '^#\\+' --color";
23 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
24 mem-top = "smem --sort rss --autosize";
25 mpl = "mplayer";
26 nf = "sudo nft list ruleset | less";
27 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
28 nixos-clean = "sudo nix-collect-garbage -d";
29 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
30 nixos-rollback = "sudo nixos-rebuild switch --rollback";
31 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
32 r = "reset";
33 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
34 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
35 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
36 s = "sudo systemctl";
37 st = "sudo systemctl status";
38 t = "tmux";
39 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
40 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
41 u = "systemctl --user";
42 ut = "systemctl --user status";
43 w1 = "watch --color --differences --interval 1";
44 w5 = "watch --color --differences --interval 5";
45 w10 = "watch --color --differences --interval 10";
46 w = "watch --color --differences";
47 watch = "watch --color --differences";
48 zfs-umount = "zfs-unmount";
49 };
50 sessionVariables = {
51 HISTCONTROL = "erasedups:ignorespace";
52 HISTSIZE = "42000";
53 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
54 };
55 initExtra = ''
56 # Alias completion
57 . ${pkgs.complete-alias}/bin/complete_alias
58 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
59
60 shopt -s globstar
61 shopt -s histappend
62 shopt -s histreedit
63 shopt -s histverify
64 # Disable ctrl-s/ctrl-q flow control
65 stty -ixon
66
67 ffmpeg-audio () {
68 for i in "$@"; do
69 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio
70 done
71 }
72 ffmpeg-opus () {
73 for i in "$@"; do
74 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
75 done
76 }
77 ibm-fan () {
78 if [ $# -gt 0 ]
79 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
80 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
81 fi
82 acpi -t
83 }
84 mkcd () {
85 mkdir -p "$1" &&
86 cd "$1"
87 }
88 mkpass () {
89 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
90 }
91 opusenc-voice () {
92 find "$@" -depth -type f -print0 | sort -n -z |
93 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
94 test -e "''${0%.*}".opus ||
95 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
96 ' {} \;
97 }
98 smartctl-tbw () {
99 device=''${1:-/dev/sda}
100 sudo smartctl -A $device |
101 { awk '
102 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
103 $0 ~ /Total_LBAs_Written/ {
104 lbas = $10;
105 bytes = $10 * 512;
106 mb = bytes / 1024^2;
107 gb = bytes / 1024^3;
108 tb = bytes / 1024^4;
109 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
110 printf "mean writes per hour: / %.2f", mb/poh
111 }
112 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
113 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
114 '; echo; } |
115 sed -e 's:/:@:' |
116 sed -e "s\$^\$$device @ \$" |
117 column -ts@
118 }
119 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
120 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
121 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
122 swaplist () {
123 lastpid=
124 swap=0
125 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
126 while IFS=: read -r file x size x
127 do
128 pid=''${file#/proc/}
129 pid=''${pid%/smaps}
130 size=''${size% kB}
131 size=''${size##* }
132 if test "$pid" = "$lastpid"
133 then swap=$(( swap + size ))
134 else
135 if test "$swap" -gt 0
136 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
137 fi
138 if test "$pid" = self
139 then break
140 else
141 lastpid=$pid
142 swap=$size
143 fi
144 fi
145 done |
146 sort -nk1,1
147 }
148 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
149 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
150
151 # Recursively mount not-mounted dataset,
152 # loading their keys if needed.
153 zfs-mount () {
154 local d
155 for d in $(zfs list -rH -o name "$@"); do
156 mountpoint /mnt/"$d" 2>/dev/null ||
157 sudo zfs mount -l "$d"
158 done
159 }
160 # Recursively unmount dataset,
161 # unloading their keys.
162 zfs-unmount () { sudo zfs unmount -u "$@"; }
163
164 # Restore the inheritance of encryptionroot,
165 # usually broken by zfs send --raw.
166 # Note that it needs to decrypt the datasets.
167 zfs-fix-encryptionroot () {
168 local d
169 zfs load-key "$1"
170 for d in $(zfs list -rHo name "$1" | tail -n +2); do
171 echo >&2 "$d"
172 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
173 zfs change-key -li "$d"
174 done
175 }
176
177 # Recursively remove all the snapshots of given datasets
178 zfs-destroy-snapshots () {
179 local d
180 for d in "$@"; do
181 zfs list -t snapshot -rHo name "$d" |
182 xargs --no-run-if-empty -L1 zfs destroy
183 done
184 }
185 '';
186 profileExtra = ''
187 '';
188 };
189 programs.direnv.enableBashIntegration = true;
190 #programs.broot.enableBashIntegration = true;
191 programs.readline = {
192 enable = mkDefault true;
193 includeSystemConfig = true;
194 bindings = {
195 # Up/Down
196 "\\e[A" = "history-search-backward";
197 "\\e[B" = "history-search-forward";
198 "\\eOA" = "history-search-backward";
199 "\\eOB" = "history-search-forward";
200
201 # Ctrl-Left/Ctrl-Right
202 "\\e[1;5C" = "forward-word";
203 "\\e[1;5D" = "backward-word";
204 "\\e[5C" = "forward-word";
205 "\\e[5D" = "backward-word";
206 "\\e\\e[C" = "forward-word";
207 "\\e\\e[D" = "backward-word";
208
209 # Home/End
210 "\\e[1~" = "beginning-of-line";
211 "\\e[4~" = "end-of-line";
212
213 # Delete/Insert
214 "\\e[3~" = "delete-char";
215 "\\e[2~" = "quoted-insert";
216
217 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
218 "\\eOF" = "end-of-line";
219 "\\eOH" = "beginning-of-line";
220
221 # For freebsd console
222 "\\e[F" = "end-of-line";
223 "\\e[H" = "beginning-of-line";
224
225 # $if term=rxvt
226 "\\e[7~" = "beginning-of-line";
227 "\\e[8~" = "end-of-line";
228 "\\eOc" = "forward-word";
229 "\\eOd" = "backward-word";
230 # $endif
231 };
232 variables = {
233 # Be 8 bit clean.
234 input-meta = mkDefault true;
235 output-meta = mkDefault true;
236 colored-completion-prefix = mkDefault true;
237 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
238 echo-control-characters = mkDefault true;
239 mark-symlinked-directories = mkDefault true;
240 menu-complete-display-prefix = mkDefault true;
241 show-all-if-ambiguous = mkDefault true;
242 show-all-if-unmodified = mkDefault true;
243 visible-stats = mkDefault false; # Append char to indicate type
244 enable-bracketed-paste = mkDefault true;
245 };
246 };
247 }