]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: add mode Up/Down bindings
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 shellAliases = {
7 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
8 c = "bat";
9 cl = "clear";
10 eic = "edit-in-commit";
11 eigg = "edit-in-git-grep";
12 emacs = "emacsclient --create-frame";
13 g = "git";
14 gg = "git grep";
15 grep = "grep --color";
16 j = "sudo journalctl -u";
17 jb = "sudo journalctl -b";
18 ju = "sudo journalctl --user -u";
19 l = "ls -alh";
20 ll = "ls -al";
21 ls = "ls --color=tty";
22 md-toc = "grep '^#\\+' --color";
23 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
24 mem-top = "smem --sort rss --autosize";
25 mpl = "mplayer";
26 nf = "sudo nft list ruleset | less";
27 nixos-clean = "sudo nix-collect-garbage -d";
28 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
29 nixos-rollback = "sudo nixos-rebuild switch --rollback";
30 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
31 r = "reset";
32 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
33 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
34 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
35 s = "sudo systemctl";
36 st = "sudo systemctl status";
37 t = "tmux";
38 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
39 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
40 u = "systemctl --user";
41 ut = "systemctl --user status";
42 w1 = "watch --color --differences --interval 1";
43 w5 = "watch --color --differences --interval 5";
44 w10 = "watch --color --differences --interval 10";
45 w = "watch --color --differences";
46 watch = "watch --color --differences";
47 zfs-umount = "zfs-unmount";
48 };
49 sessionVariables = {
50 HISTCONTROL = "erasedups:ignorespace";
51 HISTSIZE = "42000";
52 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
53 };
54 initExtra = ''
55 # Alias completion
56 . ${pkgs.complete-alias}/bin/complete_alias
57 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
58
59 shopt -s globstar
60 shopt -s histappend
61 shopt -s histreedit
62 shopt -s histverify
63 # Disable ctrl-s/ctrl-q flow control
64 stty -ixon
65
66 ibm-fan () {
67 if [ $# -gt 0 ]
68 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
69 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
70 fi
71 acpi -t
72 }
73 mkcd () {
74 mkdir -p "$1" &&
75 cd "$1"
76 }
77 mkpass () {
78 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
79 }
80 opusenc-voice () {
81 find "$@" -depth -type f -print0 | sort -n -z |
82 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
83 test -e "''${0%.*}".opus ||
84 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
85 ' {} \;
86 }
87 smartctl-tbw () {
88 device=''${1:-/dev/sda}
89 sudo smartctl -A $device |
90 { awk '
91 $0 ~ /Power_On_Hours/ { poh=$10; printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25 }
92 $0 ~ /Total_LBAs_Written/ {
93 lbas = $10;
94 bytes = $10 * 512;
95 mb = bytes / 1024^2;
96 gb = bytes / 1024^3;
97 tb = bytes / 1024^4;
98 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
99 printf "mean writes per hour: / %.2f", mb/poh
100 }
101 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
102 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
103 '; echo; } |
104 sed -e 's:/:@:' |
105 sed -e "s\$^\$$device @ \$" |
106 column -ts@
107 }
108 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
109 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
110 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
111 swaplist () {
112 lastpid=
113 swap=0
114 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
115 while IFS=: read -r file x size x
116 do
117 pid=''${file#/proc/}
118 pid=''${pid%/smaps}
119 size=''${size% kB}
120 size=''${size##* }
121 if test "$pid" = "$lastpid"
122 then swap=$(( swap + size ))
123 else
124 if test "$swap" -gt 0
125 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
126 fi
127 if test "$pid" = self
128 then break
129 else
130 lastpid=$pid
131 swap=$size
132 fi
133 fi
134 done |
135 sort -nk1,1
136 }
137 edit-in-commit () { $EDITOR $(git diff-tree --no-commit-id --name-only -r "$@"); }
138 edit-in-git-grep () { $EDITOR $(git grep --name-only --recursive "$@"); }
139
140 # Recursively mount not-mounted dataset,
141 # loading their keys if needed.
142 zfs-mount () {
143 local d
144 for d in $(zfs list -rH -o name "$@"); do
145 mountpoint /mnt/"$d" 2>/dev/null ||
146 sudo zfs mount -l "$d"
147 done
148 }
149 # Recursively unmount dataset,
150 # unloading their keys.
151 zfs-unmount () { sudo zfs unmount -u "$@"; }
152
153 # Restore the inheritance of encryptionroot,
154 # usually broken by zfs send --raw.
155 # Note that it needs to decrypt the datasets.
156 zfs-fix-encryptionroot () {
157 local d
158 zfs load-key "$1"
159 for d in $(zfs list -rHo name "$1" | tail -n +2); do
160 echo >&2 "$d"
161 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
162 zfs change-key -li "$d"
163 done
164 }
165
166 # Recursively remove all the snapshots of given datasets
167 zfs-destroy-snapshots () {
168 local d
169 for d in "$@"; do
170 zfs list -t snapshot -rHo name "$d" |
171 xargs --no-run-if-empty -L1 zfs destroy
172 done
173 }
174 '';
175 profileExtra = ''
176 '';
177 };
178 programs.direnv.enableBashIntegration = true;
179 #programs.broot.enableBashIntegration = true;
180 programs.readline = {
181 enable = mkDefault true;
182 includeSystemConfig = true;
183 bindings = {
184 # Up/Down
185 "\\e[A" = "history-search-backward";
186 "\\e[B" = "history-search-forward";
187 "\\eOA" = "history-search-backward";
188 "\\eOB" = "history-search-forward";
189
190 # Ctrl-Left/Ctrl-Right
191 "\\e[1;5C" = "forward-word";
192 "\\e[1;5D" = "backward-word";
193 "\\e[5C" = "forward-word";
194 "\\e[5D" = "backward-word";
195 "\\e\\e[C" = "forward-word";
196 "\\e\\e[D" = "backward-word";
197
198 # Home/End
199 "\\e[1~" = "beginning-of-line";
200 "\\e[4~" = "end-of-line";
201
202 # Delete/Insert
203 "\\e[3~" = "delete-char";
204 "\\e[2~" = "quoted-insert";
205
206 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
207 "\\eOF" = "end-of-line";
208 "\\eOH" = "beginning-of-line";
209
210 # For freebsd console
211 "\\e[F" = "end-of-line";
212 "\\e[H" = "beginning-of-line";
213
214 # $if term=rxvt
215 "\\e[7~" = "beginning-of-line";
216 "\\e[8~" = "end-of-line";
217 "\\eOc" = "forward-word";
218 "\\eOd" = "backward-word";
219 # $endif
220 };
221 variables = {
222 # Be 8 bit clean.
223 input-meta = mkDefault true;
224 output-meta = mkDefault true;
225 colored-completion-prefix = mkDefault true;
226 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
227 echo-control-characters = mkDefault true;
228 mark-symlinked-directories = mkDefault true;
229 menu-complete-display-prefix = mkDefault true;
230 show-all-if-ambiguous = mkDefault true;
231 show-all-if-unmodified = mkDefault true;
232 visible-stats = mkDefault false; # Append char to indicate type
233 enable-bracketed-paste = mkDefault true;
234 };
235 };
236 }