]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/xmonad.nix
graphical: move screen-locker
[julm/julm-nix.git] / home-manager / profiles / xmonad.nix
1 { pkgs, config, ... }:
2 {
3 imports = [
4 ./clipster.nix
5 ./screen-locker.nix
6 ./urxvt.nix
7 ];
8 home.file.".xmonad/xmobar.hs".source = xmonad/xmobar.hs;
9 xsession = {
10 enable = true;
11 scriptPath = ".hm-xsession";
12 initExtra = ''
13 xset dpms 380 640 1200
14 ${pkgs.xorg.xsetroot}/bin/xsetroot -solid black -fg black -bg white -cursor_name left_ptr
15 ${pkgs.pasystray}/bin/pasystray &
16 '';
17 windowManager.xmonad = {
18 enable = true;
19 inherit (pkgs) haskellPackages;
20 extraPackages = haskellPackages: [
21 haskellPackages.data-default
22 ];
23 enableContribAndExtras = true;
24 config = xmonad/xmonad.hs;
25 };
26 };
27 home.packages = [
28 pkgs.acpilight
29 pkgs.ffmpegthumbnailer
30 pkgs.gmrun
31 pkgs.light
32 #pkgs.gnome.nautilus
33 #pkgs.gtk3
34 pkgs.mate.caja-with-extensions
35 #(pkgs.writeShellScriptBin "mate-terminal" ''exec ${pkgs.rxvt-unicode}/bin/urxvtc -hold "$@"'')
36 pkgs.rofi
37 pkgs.scrot
38 pkgs.stalonetray
39 pkgs.wmname
40 pkgs.xmobar
41 pkgs.xorg.appres
42 pkgs.xorg.xev
43 pkgs.xorg.xhost
44 pkgs.xorg.xmodmap
45 pkgs.xorg.xset
46 ];
47 xresources.properties = {
48 "Xft.antialias" = true;
49 "Xft.hinting" = true;
50 "Xft.hintstyle" = "hintfull";
51 "Xft.rgba" = "rgb";
52 #"Xft.embolden" = true;
53 };
54 }