1 { config, pkgs, lib, inputs, ... }:
4 ../nixos/profiles/router.nix
5 #../nixos/profiles/debug.nix
6 ../nixos/profiles/lang-fr.nix
7 #../nixos/profiles/tor.nix
8 ../nixos/profiles/networking/remote.nix
11 aubergine/networking.nix
17 # Lower kernel's security for better performances
18 security.kernel.mitigations = "off";
20 home-manager.users.julm = {
21 imports = [ ../homes/julm.nix ];
27 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
28 # which is already world readable.
29 # printf %s $(mkpasswd -m yescrypt)
30 hashedPassword = lib.readFile aubergine/users/julm/login/hashedPassword.clear;
39 openssh.authorizedKeys.keys = map lib.readFile [
40 ../users/root/ssh/losurdo.pub
41 ../users/julm/ssh/losurdo.pub
42 ../users/julm/ssh/oignon.pub
43 ../users/julm/ssh/redmi.pub
48 openssh.authorizedKeys.keys =
49 config.users.users.julm.openssh.authorizedKeys.keys;
58 openssh.authorizedKeys.keys = map lib.readFile [
59 ../users/sevy/ssh/patate.pub
64 #systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
65 # "secret-key-files:" + aubergine/nix/secret-key-files;
68 #secret-key-files = /run/credentials/nix-daemon.service/secret-key-files.pem
72 #"http://nix-localcache.losurdo.wg"
73 #"ssh://nix-ssh@losurdo.wg?priority=30"
74 #"ssh://nix-ssh@oignon.wg?priority=30"
76 trusted-public-keys = map lib.readFile [
77 ../users/root/nix/oignon.pub
80 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
82 #environment.etc."nixpkgs".source = pkgs.path;
83 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
85 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
88 keys = map lib.readFile [
89 ../users/julm/ssh/losurdo.pub
90 ../users/sevy/ssh/patate.pub
91 ../users/julm/ssh/oignon.pub
95 environment.systemPackages = [
98 boot.extraModulePackages = [
99 #config.boot.kernelPackages.v4l2loopback
102 # This value determines the NixOS release with which your system is to be
103 # compatible, in order to avoid breaking some software such as database
104 # servers. You should change this only after NixOS release notes say you should.
105 system.stateVersion = "22.11"; # Did you read the comment?