]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
creds: change machine-id
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { config, lib, pkgs, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
8 ];
9
10 # Setting the machine-id avoids to reencrypt all credentials
11 # when reinstalling NixOS on a new drive.
12 # Manually generated with : uuidgen | tr -d -
13 environment.etc.machine-id.text = "be4a9e8cde1145c1bfcff894e36206d6";
14
15 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
16 # You should try to make this id unique among your hosts.
17 # Manually generated with : uuidgen | head -c8
18 networking.hostId = "408a404a";
19
20 /*
21 boot.loader.efi = {
22 canTouchEfiVariables = true;
23 efiSysMountPoint = "/boot/efi";
24 };
25 */
26 boot.loader.grub = {
27 enable = true;
28 version = 2;
29 devices = [
30 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
31 "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
32 ];
33 configurationLimit = 9;
34
35 #zfsSupport = true;
36 #efiSupport = true;
37 #enableCryptodisk = true;
38 };
39 boot.tmpOnTmpfs = true;
40
41 fileSystems."/" =
42 { device = "/dev/disk/by-partlabel/${hostName}_sd_root";
43 fsType = "ext4";
44 };
45 fileSystems."/boot/efi" =
46 { device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
47 fsType = "vfat";
48 };
49 /*
50 swapDevices = [
51 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
52 randomEncryption = {
53 enable = true;
54 cipher = "aes-xts-plain64";
55 source = "/dev/urandom";
56 };
57 }
58 ];
59 */
60
61 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
62 boot.extraModulePackages = [
63 #config.boot.kernelPackages.exfat-nofuse
64 ];
65
66 powerManagement.powertop.enable = true;
67 #services.fprintd.enable = true;
68
69 /*
70 fileSystems."/" =
71 { device = "${hostName}/root";
72 fsType = "zfs";
73 };
74 fileSystems."/nix" =
75 { device = "${hostName}/nix";
76 fsType = "zfs";
77 };
78 fileSystems."/var" =
79 { device = "${hostName}/var";
80 fsType = "zfs";
81 };
82 */
83
84 hardware.pulseaudio.enable = lib.mkDefault true;
85 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
86
87 }