]> Git — Sourcephile - julm/julm-nix.git/blob - homes/programs/urxvt.nix
openssh: fix startup
[julm/julm-nix.git] / homes / programs / urxvt.nix
1 {
2 xresources.properties = {
3 "URxvt*background" = "black";
4 "URxvt*buffered" = "true";
5 "URxvt*cursorBlink" = "on";
6 "URxvt*cursorColor" = "#00B10B";
7 "URxvt*cursorColor2" = "black";
8 "URxvt*cutchars" = ''"()*,;<>[]{}|│`\"'#::、。"'';
9 "URxvt*depth" = "32";
10 "URxvt*fading" = "0";
11 "URxvt*font" = "xft:DejaVu Sans Mono:size=6";
12 "URxvt*font-size.step" = "1";
13 "URxvt*foreground" = "white";
14 "URxvt*geometry" = "61x20";
15 "URxvt*highlightColor" = "red";
16 "URxvt*insecure" = "True";
17 "URxvt*internalBorder" = "2";
18 "URxvt*iso14755_52" = "False";
19 "URxvt*jumpScroll" = "on";
20 "URxvt*keysym.C-Down" = "perl:font-size:decrease";
21 "URxvt*keysym.C-ISO_Left_Tab" = "\\033[27;6;9~";
22 "URxvt*keysym.C-S-Down" = "perl:font-size:decglobal";
23 "URxvt*keysym.C-S-Up" = "perl:font-size:incglobal";
24 "URxvt*keysym.C-Tab" = "\\033[27;5;9~";
25 "URxvt*keysym.C-Up" = "perl:font-size:increase";
26 "URxvt*keysym.KP_End" = "\\033[4~";
27 "URxvt*keysym.KP_Enter" = "\\n";
28 "URxvt*keysym.KP_Home" = "\\033[1~";
29 "URxvt*letterSpace" = "0";
30 "URxvt*lineSpace" = "0";
31 "URxvt*meta8" = "False";
32 "URxvt*perl-ext" = "default";
33 "URxvt*perl-ext-common" = "default,font-size";
34 "URxvt*pointerColor" = "green";
35 "URxvt*pointerColor2" = "black";
36 "URxvt*reverseVideo" = "false";
37 "URxvt*saveLines" = "0";
38 "URxvt*scrollBar_floating" = "on";
39 "URxvt*scrollBar_right" = "on";
40 "URxvt*scrollColor" = "grey20";
41 "URxvt*scrollTtyKeypress" = "on";
42 "URxvt*scrollTtyOutput" = "off";
43 "URxvt*scrollWithBuffer" = "on";
44 "URxvt*scrollbar*foreground" = "blue";
45 "URxvt*scrollstyle" = "plain";
46 "URxvt*termName" = "xterm-256color";
47 "URxvt*troughColor" = "blue";
48 "URxvt*urgentOnBell" = "true";
49 "URxvt*visualBell" = "off";
50 /*
51 !URxvt.urlLauncher: elinks
52 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=9:antialias=true
53 !URxvt*font: xft:DejaVu Sans Mono:size=6.38:weight=medium:antialias=true:hintstyle=100:autohint=0,xft:unifont,xft:freemono:pixelsize=13,xft:Code2000:antialias=false
54 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=24
55 !URxvt*font: xft:Inconsolata:pixelsize=10
56 !URxvt*font: xft:Fira Code:pixelsize=10
57 !URxvt*scrollWithBuffer: true
58 !: hinting=true:slant=0:weight=50
59 !URxvt*boldFont: xft:DejaVu Sans Mono:bold:pixelsize=9:antialias=true:hinting=true
60 !urxvt*boldColors: on
61 ! Allow switching of font sizes
62 !URxvt.keysym.C-M-minus: command:\033]710;xft:Terminus-8:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=80,xft:Inconsolata-10,x:-schumacher-clean-medium-r-normal-*-12-*-*-*-c-*-iso10646-1,x:-misc-fixed-medium-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-8:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=200,x:-misc-fixed-bold-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-bold-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-8:slant=110:weight=80,xft:DejaVu Sans Mono-8:slant=110:weight=80\007\033]713;xft:Terminus-8:slant=110:weight=200,xft:DejaVu Sans Mono-8:slant=110:weight=200\007
63 !URxvt.keysym.C-M-equal: command:\033]710;xft:Terminus-14:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=80,xft:Inconsolata-16,x:-gnu-unifont-medium-r-normal-*-17-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-14:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=200,x:-misc-fixed-medium-r-normal-*-20-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-*-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-14:slant=110:weight=80,xft:DejaVu Sans Mono-14:slant=110:weigth=80\007\033]713;xft:Terminus-14:slant=110:weight=200,xft:DejaVu Sans Mono-14:slant=110:weight=200\007
64 !URxvt.iso14755: False
65 !URxvt.perl-ext-common: default,matcher
66 */
67 };
68 }