]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/tmux.nix
nix: format
[julm/julm-nix.git] / home-manager / profiles / tmux.nix
1 { lib, ... }:
2 {
3 programs.tmux = {
4 enable = lib.mkDefault true;
5 baseIndex = 1;
6 clock24 = true;
7 customPaneNavigationAndResize = true;
8 extraConfig = builtins.readFile ./tmux.conf;
9 historyLimit = 10000;
10 keyMode = "vi";
11 secureSocket = false; # So that it survives user's log-out
12 sensibleOnTop = true;
13 shortcut = "C-a";
14 terminal = "screen-256color";
15 };
16 }