]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/zsh.nix
nix: format
[julm/julm-nix.git] / home-manager / profiles / zsh.nix
1 {
2 programs.zsh = {
3 enableAutosuggestions = true;
4 history.extended = true;
5 oh-my-zsh = {
6 enable = true;
7 plugins = [
8 #"archlinux"
9 "git-extras"
10 "git"
11 "gitfast"
12 #"github"
13 ];
14 #theme = "frozencow";
15 theme = "agnoster";
16 };
17 loginExtra = ''
18 setopt extendedglob
19 source $HOME/.aliases
20 bindkey '^R' history-incremental-pattern-search-backward
21 bindkey '^F' history-incremental-pattern-search-forward
22 '';
23 };
24 programs.direnv.enableZshIntegration = true;
25 }