]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/aubergine/hardware.nix
nix: format
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
1 { lib, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
8 ];
9
10 # Setting the machine-id avoids to reencrypt all credentials
11 # when reinstalling NixOS on a new drive.
12 # Manually generated with : uuidgen | tr -d -
13 environment.etc.machine-id.text = "be4a9e8cde1145c1bfcff894e36206d6";
14
15 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
16 # You should try to make this id unique among your hosts.
17 # Manually generated with : uuidgen | head -c8
18 networking.hostId = "408a404a";
19
20 /*
21 boot.loader.efi = {
22 canTouchEfiVariables = true;
23 efiSysMountPoint = "/boot/efi";
24 };
25 */
26 boot.loader.grub = {
27 enable = true;
28 version = 2;
29 devices = [
30 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
31 "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
32 ];
33 configurationLimit = 9;
34
35 #zfsSupport = true;
36 #efiSupport = true;
37 #enableCryptodisk = true;
38 };
39 boot.tmpOnTmpfs = true;
40
41 fileSystems."/" =
42 {
43 device = "/dev/disk/by-partlabel/${hostName}_sd_root";
44 fsType = "ext4";
45 };
46 fileSystems."/boot/efi" =
47 {
48 device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
49 fsType = "vfat";
50 };
51 /*
52 swapDevices = [
53 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
54 randomEncryption = {
55 enable = true;
56 cipher = "aes-xts-plain64";
57 source = "/dev/urandom";
58 };
59 }
60 ];
61 */
62
63 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
64 boot.extraModulePackages = [
65 #config.boot.kernelPackages.exfat-nofuse
66 ];
67
68 powerManagement.powertop.enable = true;
69 #services.fprintd.enable = true;
70
71 /*
72 fileSystems."/" =
73 { device = "${hostName}/root";
74 fsType = "zfs";
75 };
76 fileSystems."/nix" =
77 { device = "${hostName}/nix";
78 fsType = "zfs";
79 };
80 fileSystems."/var" =
81 { device = "${hostName}/var";
82 fsType = "zfs";
83 };
84 */
85
86 hardware.pulseaudio.enable = lib.mkDefault true;
87 #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
88
89 }