]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate/hardware.nix
nix: format
[julm/julm-nix.git] / hosts / patate / hardware.nix
1 { hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/X200.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
7 ];
8
9 boot.loader.grub = {
10 enable = true;
11 version = 2;
12 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
13 configurationLimit = 3;
14 };
15
16 fileSystems."/boot" =
17 {
18 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
19 fsType = "ext2";
20 };
21 fileSystems."/boot/efi" =
22 {
23 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
24 fsType = "vfat";
25 };
26 swapDevices = [
27 {
28 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
29 randomEncryption = {
30 enable = true;
31 cipher = "aes-xts-plain64";
32 source = "/dev/urandom";
33 };
34 }
35 ];
36
37 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
38 # You should try to make this id unique among your hosts.
39 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
40 networking.hostId = "ec2adb40";
41
42 boot.supportedFilesystems = [ "ntfs" "vfat" ];
43 boot.extraModulePackages = [
44 #config.boot.kernelPackages.exfat-nofuse
45 ];
46
47 powerManagement.powertop.enable = true;
48
49 fileSystems."/" =
50 {
51 device = "${hostName}/root";
52 fsType = "zfs";
53 };
54 fileSystems."/nix" =
55 {
56 device = "${hostName}/nix";
57 fsType = "zfs";
58 };
59 fileSystems."/home/sevy" =
60 {
61 device = "${hostName}/home";
62 fsType = "zfs";
63 };
64 fileSystems."/home/sevy/Documents" =
65 {
66 device = "${hostName}/home/Documents";
67 fsType = "zfs";
68 };
69 fileSystems."/home/sevy/Images" =
70 {
71 device = "${hostName}/home/Images";
72 fsType = "zfs";
73 };
74 fileSystems."/home/sevy/Téléchargements" =
75 {
76 device = "${hostName}/home/Downloads";
77 fsType = "zfs";
78 };
79 fileSystems."/home/sevy/.thunderbird" =
80 {
81 device = "${hostName}/home/Mails";
82 fsType = "zfs";
83 };
84 fileSystems."/home/sevy/Vidéos" =
85 {
86 device = "${hostName}/home/Videos";
87 fsType = "zfs";
88 };
89 fileSystems."/var" =
90 {
91 device = "${hostName}/var";
92 fsType = "zfs";
93 };
94 fileSystems."/var/cache" =
95 {
96 device = "${hostName}/var/cache";
97 fsType = "zfs";
98 };
99 fileSystems."/var/log" =
100 {
101 device = "${hostName}/var/log";
102 fsType = "zfs";
103 };
104 fileSystems."/var/tmp" =
105 {
106 device = "${hostName}/var/tmp";
107 fsType = "zfs";
108 };
109
110 }