2 # On a remote headless server: always reboot on a kernel panic,
3 # to not have to physically go power cycle the server.
4 # Which may happen for instance if the wrong ZFS password is used
5 # but the boot is manually forced to continue.
6 # Using kernelParams instead of kernel.sysctl
7 # sets this up as soon as the initrd.
8 boot.kernelParams = [ "panic=10" ];
10 programs.gnupg.agent.pinentryFlavor = "curses";
11 programs.mosh.enable = mkDefault true;
13 # Always try to start all the units (default.target)
14 # because systemd's emergency shell does not try to start sshd.
15 # https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_host
16 systemd.enableEmergencyMode = false;
18 services.openssh.enable = true;