]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/laptop.nix
nix: tweak nix-daemon and nix-gc schedulings
[julm/julm-nix.git] / nixos / profiles / laptop.nix
1 { lib, ... }:
2 {
3 systemd.services.nix-daemon.serviceConfig = {
4 CPUSchedulingPolicy = lib.mkForce "idle";
5 IOSchedulingClass = lib.mkForce "idle";
6 # 0: high priority, 7: low priority
7 IOSchedulingPriority = lib.mkForce 4;
8 Nice = 19;
9 };
10
11 systemd.services.nix-gc.serviceConfig = {
12 CPUSchedulingPolicy = "idle";
13 IOSchedulingClass = "idle";
14 IOSchedulingPriority = 7;
15 Nice = 19;
16 };
17
18 systemd.sleep.extraConfig = ''
19 AllowSuspend=yes
20 AllowHibernation=yes
21 '';
22
23 }