]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/router.nix
nix: tweak nix-daemon and nix-gc schedulings
[julm/julm-nix.git] / nixos / profiles / router.nix
1 { lib, ... }:
2 {
3 systemd.sleep.extraConfig = ''
4 AllowSuspend=no
5 AllowHibernation=no
6 '';
7
8 systemd.services.nix-daemon.serviceConfig = {
9 CPUSchedulingPolicy = lib.mkForce "batch";
10 IOSchedulingClass = lib.mkForce "best-effort";
11 # 0: high priority, 7: low priority
12 IOSchedulingPriority = lib.mkForce 4;
13 };
14
15 systemd.services.nix-gc.serviceConfig = {
16 CPUSchedulingPolicy = "batch";
17 IOSchedulingClass = "best-effort";
18 IOSchedulingPriority = 7;
19 Nice = 5;
20 };
21
22 }