]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate/hardware.nix
nix: revamp settings in nixos/profiles
[julm/julm-nix.git] / hosts / patate / hardware.nix
1 { config, lib, pkgs, hostName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/acpid.nix
5 ../../nixos/profiles/hardware/thinkpad.nix
6 ../../nixos/profiles/zfs.nix
7 ../../nixos/profiles/zramSwap.nix
8 ];
9
10 boot.loader.grub = {
11 enable = true;
12 version = 2;
13 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
14 configurationLimit = 3;
15 };
16
17 fileSystems."/boot" =
18 { device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
19 fsType = "ext2";
20 };
21 fileSystems."/boot/efi" =
22 { device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
23 fsType = "vfat";
24 };
25 swapDevices = [
26 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
27 randomEncryption = {
28 enable = true;
29 cipher = "aes-xts-plain64";
30 source = "/dev/urandom";
31 };
32 }
33 ];
34
35 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
36 # You should try to make this id unique among your hosts.
37 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
38 networking.hostId = "ec2adb40";
39
40 boot.supportedFilesystems = [ "ntfs" "vfat" ];
41 boot.extraModulePackages = [
42 #config.boot.kernelPackages.exfat-nofuse
43 ];
44
45 fileSystems."/" =
46 { device = "${hostName}/root";
47 fsType = "zfs";
48 };
49 fileSystems."/nix" =
50 { device = "${hostName}/nix";
51 fsType = "zfs";
52 };
53 fileSystems."/home/sevy" =
54 { device = "${hostName}/home";
55 fsType = "zfs";
56 };
57 fileSystems."/home/sevy/Documents" =
58 { device = "${hostName}/home/Documents";
59 fsType = "zfs";
60 };
61 fileSystems."/home/sevy/Images" =
62 { device = "${hostName}/home/Images";
63 fsType = "zfs";
64 };
65 fileSystems."/home/sevy/Téléchargements" =
66 { device = "${hostName}/home/Downloads";
67 fsType = "zfs";
68 };
69 fileSystems."/home/sevy/.thunderbird" =
70 { device = "${hostName}/home/Mails";
71 fsType = "zfs";
72 };
73 fileSystems."/home/sevy/Vidéos" =
74 { device = "${hostName}/home/Videos";
75 fsType = "zfs";
76 };
77 fileSystems."/var" =
78 { device = "${hostName}/var";
79 fsType = "zfs";
80 };
81 fileSystems."/var/cache" =
82 { device = "${hostName}/var/cache";
83 fsType = "zfs";
84 };
85 fileSystems."/var/log" =
86 { device = "${hostName}/var/log";
87 fsType = "zfs";
88 };
89 fileSystems."/var/tmp" =
90 { device = "${hostName}/var/tmp";
91 fsType = "zfs";
92 };
93
94 }