]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/bash.nix
bash: tweak aliases
[julm/julm-nix.git] / home-manager / profiles / bash.nix
1 { pkgs, lib, ... }:
2 with lib;
3 {
4 programs.bash = {
5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
7 shellAliases = {
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
10 c = "bat";
11 cl = "clear";
12 emacs = "emacsclient --create-frame";
13 grep = "grep --color";
14 j = "sudo journalctl -u";
15 jb = "sudo journalctl -b";
16 ju = "sudo journalctl --user -u";
17 l = "ls -alh";
18 ll = "ls -al";
19 ls = "ls --color=tty";
20 md-toc = "grep '^#\\+' --color";
21 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
22 mem-top = "smem --sort rss --autosize";
23 mpl = "mplayer";
24 n = "networkctl";
25 nf = "sudo nft list ruleset | less";
26 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
27 nixos-clean = "sudo nix-collect-garbage -d";
28 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
29 nixos-rollback = "sudo nixos-rebuild switch --rollback";
30 nt = "networkctl status";
31 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
32 r = "reset";
33 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
34 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
35 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
36 s = "sudo systemctl";
37 sr = "sudo systemctl restart";
38 st = "sudo systemctl status";
39 t = "tmux";
40 t0 = "tmux new -t 0";
41 t1 = "tmux new -t 1";
42 t2 = "tmux new -t 2";
43 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
44 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
45 u = "systemctl --user";
46 ur = "systemctl --user restart";
47 ut = "systemctl --user status";
48 w = "watch --color --differences";
49 w1 = "watch --color --differences --interval 1";
50 w10 = "watch --color --differences --interval 10";
51 w5 = "watch --color --differences --interval 5";
52 watch = "watch --color --differences";
53 z = "zfs";
54 ze = "sudo zpool export";
55 zfs-umount = "zfs-unmount";
56 zi = "sudo zpool import";
57 zl = "zfs list";
58 zlb = "zfs list -t bookmarks";
59 zls = "zfs list -t snap";
60 zm = "zfs-mount";
61 zp = "sudo zpool";
62 zs = "zpool status";
63 zs5 = "w5 zpool status";
64 zu = "zfs-unmount";
65 };
66 historyControl = [ "erasedups" "ignorespace" ];
67 historyIgnore = [
68 "torify"
69 "mpv"
70 ];
71 historySize = 42000;
72 sessionVariables = {
73 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
74 };
75 initExtra = ''
76 # Alias completion
77 . ${pkgs.complete-alias}/bin/complete_alias
78 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
79
80 shopt -s globstar
81 shopt -s histappend
82 shopt -s histreedit
83 shopt -s histverify
84 # Disable ctrl-s/ctrl-q flow control
85 stty -ixon
86
87 ffmpeg-audio () {
88 for i in "$@"; do
89 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
90 done
91 }
92 ffmpeg-opus () {
93 for i in "$@"; do
94 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
95 done
96 }
97 opusenc-voice () {
98 find "$@" -depth -type f -print0 | sort -n -z |
99 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
100 test -e "''${0%.*}".opus ||
101 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
102 ' {} \;
103 }
104 ibm-fan () {
105 if [ $# -gt 0 ]
106 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
107 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
108 fi
109 acpi -t
110 }
111 mkcd () {
112 mkdir -p "$1" &&
113 cd "$1"
114 }
115 mkpass () {
116 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
117 }
118 smartctl-tbw () {
119 device=''${1:-/dev/sda}
120 sudo smartctl -A $device |
121 { awk '
122 $0 ~ /Power_On_Hours/ {
123 poh=$10;
124 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
125 }
126 $0 ~ /Total_LBAs_Written/ {
127 lbas = $10;
128 bytes = $10 * 512;
129 mb = bytes / 1024^2;
130 gb = bytes / 1024^3;
131 tb = bytes / 1024^4;
132 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
133 printf "mean writes per hour / %.2f", mb/poh
134 }
135 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
136 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
137 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
138 '; echo; } |
139 sed -e 's:/:@:' |
140 sed -e "s\$^\$$device @ \$" |
141 column -ts@
142 }
143 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
144 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
145 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
146 swaplist () {
147 lastpid=
148 swap=0
149 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
150 while IFS=: read -r file x size x
151 do
152 pid=''${file#/proc/}
153 pid=''${pid%/smaps}
154 size=''${size% kB}
155 size=''${size##* }
156 if test "$pid" = "$lastpid"
157 then swap=$(( swap + size ))
158 else
159 if test "$swap" -gt 0
160 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
161 fi
162 if test "$pid" = self
163 then break
164 else
165 lastpid=$pid
166 swap=$size
167 fi
168 fi
169 done |
170 sort -nk1,1
171 }
172
173 # Recursively mount not-mounted dataset,
174 # loading their keys if needed.
175 zfs-mount () {
176 (
177 set -e
178 for d in $(zfs list -rH -o name "$@"); do
179 mountpoint /mnt/"$d" 2>/dev/null ||
180 sudo zfs mount -l "$d"
181 done
182 )
183 }
184 # Recursively unmount dataset,
185 # unloading their keys.
186 zfs-unmount () { sudo zfs unmount -u "$@"; }
187
188 # Create bookmarks for all the snapshots of the given datasets.
189 # Bookmarks are only useful on source datasets
190 # But syncoid --create-bookmark only creates
191 # a bookmark for the latest snapshot,
192 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
193 zfs-fix-bookmarks () {
194 local d
195 local -
196 set -x
197 for d in "$@"; do
198 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
199 zfs bookmark "$s" "''${s//@/#}"
200 done
201 done
202 }
203
204 # Restore the inheritance of encryptionroot,
205 # usually broken by zfs send --raw.
206 # Note that it needs to decrypt the datasets.
207 zfs-fix-encryptionroot () {
208 local d
209 zfs load-key "$1"
210 for d in $(zfs list -rHo name "$1" | tail -n +2); do
211 echo >&2 "$d"
212 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
213 zfs change-key -li "$d"
214 done
215 }
216
217 # Recursively remove all the snapshots of given datasets
218 zfs-destroy-snapshots () {
219 local d
220 for d in "$@"; do
221 zfs list -t snapshot -rHo name "$d" |
222 xargs --no-run-if-empty -L1 zfs destroy
223 done
224 }
225 '';
226 profileExtra = ''
227 '';
228 };
229 programs.direnv.enableBashIntegration = true;
230 #programs.broot.enableBashIntegration = true;
231 programs.readline = {
232 enable = mkDefault true;
233 includeSystemConfig = true;
234 bindings = {
235 # Up/Down
236 "\\e[A" = "history-search-backward";
237 "\\e[B" = "history-search-forward";
238 "\\eOA" = "history-search-backward";
239 "\\eOB" = "history-search-forward";
240
241 # Ctrl-Left/Ctrl-Right
242 "\\e[1;5C" = "forward-word";
243 "\\e[1;5D" = "backward-word";
244 "\\e[5C" = "forward-word";
245 "\\e[5D" = "backward-word";
246 "\\e\\e[C" = "forward-word";
247 "\\e\\e[D" = "backward-word";
248
249 # Home/End
250 "\\e[1~" = "beginning-of-line";
251 "\\e[4~" = "end-of-line";
252
253 # Delete/Insert
254 "\\e[3~" = "delete-char";
255 "\\e[2~" = "quoted-insert";
256
257 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
258 "\\eOF" = "end-of-line";
259 "\\eOH" = "beginning-of-line";
260
261 # For freebsd console
262 "\\e[F" = "end-of-line";
263 "\\e[H" = "beginning-of-line";
264
265 # $if term=rxvt
266 "\\e[7~" = "beginning-of-line";
267 "\\e[8~" = "end-of-line";
268 "\\eOc" = "forward-word";
269 "\\eOd" = "backward-word";
270 # $endif
271 };
272 variables = {
273 # Be 8 bit clean.
274 input-meta = mkDefault true;
275 output-meta = mkDefault true;
276 colored-completion-prefix = mkDefault true;
277 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
278 echo-control-characters = mkDefault true;
279 mark-symlinked-directories = mkDefault true;
280 menu-complete-display-prefix = mkDefault true;
281 show-all-if-ambiguous = mkDefault true;
282 show-all-if-unmodified = mkDefault true;
283 visible-stats = mkDefault false; # Append char to indicate type
284 enable-bracketed-paste = mkDefault true;
285 };
286 };
287 }