1 { inputs, pkgs, lib, config, ... }:
5 inputs.nix-doom-emacs.hmModule
7 programs.doom-emacs = {
8 enable = config.host.developer;
10 "${config.home.homeDirectory}/.doom.d";
13 #enable = true; # Use with emacsclient -c
14 package = config.programs.emacs.package;
17 home.sessionPath = [ "${config.xdg.configHome}/emacs/bin" ];
18 home.sessionVariables = {
19 DOOMDIR = "${config.xdg.configHome}/doom-config";
20 DOOMLOCALDIR = "${config.xdg.configHome}/doom-local";
23 #"doom-config/config.el".text = emacs/config.el;
24 #"doom-config/init.el".source = emacs/init.el;
25 "doom-config/packages.el".text = "";
27 source = inputs.doom-emacs;
28 onChange = "${pkgs.writeShellScript "doom-change" ''
29 export DOOMDIR="${config.home.sessionVariables.DOOMDIR}"
30 export DOOMLOCALDIR="${config.home.sessionVariables.DOOMLOCALDIR}"
31 if [ ! -d "$DOOMLOCALDIR" ]; then
32 ${config.xdg.configHome}/emacs/bin/doom -y install
34 ${config.xdg.configHome}/emacs/bin/doom -y sync -u
40 home.packages = with pkgs; [
41 # DOOM Emacs dependencies
43 (ripgrep.override { withPCRE2 = true; })
48 #nodePackages.javascript-typescript-langserver
52 emacs-all-the-icons-fonts