1 { config, pkgs, lib, inputs, ... }:
4 #../nixos/profiles/debug.nix
5 ../nixos/profiles/lang-fr.nix
6 #../nixos/profiles/tor.nix
8 aubergine/networking.nix
11 # Lower kernel's security for better performances
12 boot.kernelParams = [ "mitigations=off" ];
14 home-manager.users.julm = {
15 imports = [ ../homes/julm.nix ];
17 systemd.services.home-manager-julm.postStart = ''
18 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
23 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
24 # which is already world readable.
25 # printf %s $(mkpasswd -m md5crypt)
26 hashedPassword = lib.readFile aubergine/users/julm/login/hashedPassword.clear;
34 # If created, zfs-mount.service would require:
35 # zfs set overlay=yes ${hostName}/home
37 openssh.authorizedKeys.keys = map lib.readFile [
38 ../users/root/ssh/losurdo.pub
39 ../users/julm/ssh/losurdo.pub
40 ../users/julm/ssh/oignon.pub
41 ../users/julm/ssh/redmi.pub
46 openssh.authorizedKeys.keys =
47 config.users.users.julm.openssh.authorizedKeys.keys;
50 #systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
51 # "secret-key-files:" + aubergine/nix/secret-key-files;
54 #secret-key-files = /run/credentials/nix-daemon.service/secret-key-files.pem
57 trusted-users = [ config.users.users."julm".name ];
59 #"http://nix-localcache.losurdo.wg"
60 #"ssh://nix-ssh@losurdo.wg?priority=30"
61 #"ssh://nix-ssh@oignon.wg?priority=30"
63 trusted-public-keys = map lib.readFile [
64 ../users/root/nix/oignon.pub
67 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
69 #environment.etc."nixpkgs".source = pkgs.path;
70 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
72 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
75 keys = map lib.readFile [
76 ../users/julm/ssh/losurdo.pub
77 ../users/sevy/ssh/patate.pub
78 ../users/julm/ssh/oignon.pub
82 environment.systemPackages = [
85 boot.extraModulePackages = [
86 #config.boot.kernelPackages.v4l2loopback
89 # This value determines the NixOS release with which your system is to be
90 # compatible, in order to avoid breaking some software such as database
91 # servers. You should change this only after NixOS release notes say you should.
92 system.stateVersion = "22.11"; # Did you read the comment?