]> Git — Sourcephile - julm/julm-nix.git/blob - home-manager/profiles/urxvt.nix
xmonad: fix multiscreen support
[julm/julm-nix.git] / home-manager / profiles / urxvt.nix
1 { pkgs, ... }:
2 {
3 home.packages = [
4 pkgs.rxvt-unicode
5 ];
6 systemd.user.services.urxvt = {
7 Unit = {
8 Description = "RXVT-Unicode daemon";
9 After = [ "graphical-session-pre.target" ];
10 PartOf = [ "graphical-session.target" ];
11 };
12 Service = {
13 ExecStart = "${pkgs.rxvt-unicode}/bin/urxvtd -q -o";
14 Restart = "always";
15 };
16 Install = { WantedBy = [ "graphical-session.target" ]; };
17 };
18 xresources.properties = {
19 "URxvt*background" = "black";
20 "URxvt*buffered" = "true";
21 "URxvt*cursorBlink" = "on";
22 "URxvt*cursorColor" = "#00B10B";
23 "URxvt*cursorColor2" = "black";
24 "URxvt*cutchars" = ''"()*,;<>[]{}|│`\"'#:、。"'';
25 "URxvt*depth" = "32";
26 "URxvt*fading" = "0";
27 "URxvt*font" = "xft:DejaVu Sans Mono:size=6";
28 "URxvt*font-size.step" = "1";
29 "URxvt*foreground" = "white";
30 "URxvt*geometry" = "61x20";
31 "URxvt*highlightColor" = "red";
32 "URxvt*insecure" = "True";
33 "URxvt*internalBorder" = "2";
34 "URxvt*iso14755_52" = "False";
35 "URxvt*jumpScroll" = "on";
36 "URxvt*keysym.C-Down" = "perl:font-size:decrease";
37 "URxvt*keysym.C-ISO_Left_Tab" = "\\033[27;6;9~";
38 "URxvt*keysym.C-S-Down" = "perl:font-size:decglobal";
39 "URxvt*keysym.C-S-Up" = "perl:font-size:incglobal";
40 "URxvt*keysym.C-Tab" = "\\033[27;5;9~";
41 "URxvt*keysym.C-Up" = "perl:font-size:increase";
42 "URxvt*keysym.KP_End" = "\\033[4~";
43 "URxvt*keysym.KP_Enter" = "\\n";
44 "URxvt*keysym.KP_Home" = "\\033[1~";
45 "URxvt*keysym.M-u" = "perl:url-select:select_next";
46 "URxvt*letterSpace" = "0";
47 "URxvt*lineSpace" = "0";
48 "URxvt*meta8" = "False";
49 "URxvt*perl-ext" = "default";
50 "URxvt*perl-ext-common" = "default,font-size,url-select";
51 "URxvt*pointerColor" = "green";
52 "URxvt*pointerColor2" = "black";
53 "URxvt*reverseVideo" = "false";
54 "URxvt*saveLines" = "0";
55 "URxvt*scrollBar_floating" = "on";
56 "URxvt*scrollBar_right" = "on";
57 "URxvt*scrollColor" = "grey20";
58 "URxvt*scrollTtyKeypress" = "on";
59 "URxvt*scrollTtyOutput" = "off";
60 "URxvt*scrollWithBuffer" = "on";
61 "URxvt*scrollbar*foreground" = "blue";
62 "URxvt*scrollstyle" = "plain";
63 "URxvt*termName" = "xterm-256color";
64 "URxvt*troughColor" = "blue";
65 "URxvt*urgentOnBell" = "true";
66 "URxvt*url-select.launcher" = "xdg-open";
67 "URxvt*url-select.underline" = "true";
68 "URxvt*visualBell" = "off";
69 /*
70 !URxvt.urlLauncher: elinks
71 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=9:antialias=true
72 !URxvt*font: xft:DejaVu Sans Mono:size=6.38:weight=medium:antialias=true:hintstyle=100:autohint=0,xft:unifont,xft:freemono:pixelsize=13,xft:Code2000:antialias=false
73 !URxvt*font: xft:DejaVu Sans Mono:pixelsize=24
74 !URxvt*font: xft:Inconsolata:pixelsize=10
75 !URxvt*font: xft:Fira Code:pixelsize=10
76 !URxvt*scrollWithBuffer: true
77 !: hinting=true:slant=0:weight=50
78 !URxvt*boldFont: xft:DejaVu Sans Mono:bold:pixelsize=9:antialias=true:hinting=true
79 !urxvt*boldColors: on
80 ! Allow switching of font sizes
81 !URxvt.keysym.C-M-minus: command:\033]710;xft:Terminus-8:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=80,xft:Inconsolata-10,x:-schumacher-clean-medium-r-normal-*-12-*-*-*-c-*-iso10646-1,x:-misc-fixed-medium-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-8:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-9:slant=0:weight=200,x:-misc-fixed-bold-r-semicondensed-*-13-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-bold-r-normal-*-12-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-8:slant=110:weight=80,xft:DejaVu Sans Mono-8:slant=110:weight=80\007\033]713;xft:Terminus-8:slant=110:weight=200,xft:DejaVu Sans Mono-8:slant=110:weight=200\007
82 !URxvt.keysym.C-M-equal: command:\033]710;xft:Terminus-14:slant=0:weight=80,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=80,xft:Inconsolata-16,x:-gnu-unifont-medium-r-normal-*-17-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-medium-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]711;xft:Terminus-14:slant=0:weight=200,xft:DejaVu\ Sans\ Mono-14:slant=0:weight=200,x:-misc-fixed-medium-r-normal-*-20-*-*-*-c-*-iso10646-1,x:-b&h-lucidatypewriter-*-r-normal-*-17-*-*-*-m-*-iso10646-1\007\033]712;xft:Terminus-14:slant=110:weight=80,xft:DejaVu Sans Mono-14:slant=110:weigth=80\007\033]713;xft:Terminus-14:slant=110:weight=200,xft:DejaVu Sans Mono-14:slant=110:weight=200\007
83 !URxvt.iso14755: False
84 !URxvt.perl-ext-common: default,matcher
85 */
86 };
87 }