]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
nebula: comment about possible cipher
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/direnv.nix
7 ../../../home-manager/profiles/drawing.nix
8 ../../../home-manager/profiles/gaming.nix
9 ../../../home-manager/profiles/git.nix
10 ../../../home-manager/profiles/gnupg.nix
11 ../../../home-manager/profiles/gnupg.nix
12 ../../../home-manager/profiles/graphical.nix
13 ../../../home-manager/profiles/lf.nix
14 ../../../home-manager/profiles/mpv.nix
15 ../../../home-manager/profiles/networking.nix
16 ../../../home-manager/profiles/nix.nix
17 ../../../home-manager/profiles/radio.nix
18 ../../../home-manager/profiles/science.nix
19 ../../../home-manager/profiles/video.nix
20 ../../../home-manager/profiles/wireless.nix
21 ../../../home-manager/profiles/yt-dlp.nix
22
23 ../../../home-manager/profiles/emacs.nix
24 ../../../home-manager/profiles/firefox.nix
25 ../../../home-manager/profiles/xmonad.nix
26 ../../../home-manager/profiles/ghc.nix
27
28 ../mails.nix
29 ];
30 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
31 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
32 home.sessionVariables = {
33 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
34 };
35 home.packages = [
36 pkgs.ghostscript
37 #pkgs.go-mtpfs
38 pkgs.ntfs3g
39 pkgs.p7zip
40 pkgs.unar
41 pkgs.pdftk
42 pkgs.vips
43 pkgs.poppler_utils
44 # psnup conflicts with pkgs.texlive.combined.scheme-*
45 (lib.lowPrio pkgs.psutils)
46 pkgs.ink
47 pkgs.djview
48 pkgs.qpdf
49 pkgs.libreoffice
50 pkgs.calibre
51 pkgs.zotero
52 pkgs.evince
53 pkgs.marble
54 pkgs.gcompris
55 pkgs.frozen-bubble
56 pkgs.neverball
57 pkgs.tuxpaint
58 pkgs.xsane
59 pkgs.stig
60 pkgs.gthumb
61 pkgs.thunderbird
62 #pkgs.chromium
63 pkgs.fluidsynth
64 pkgs.gpsbabel
65 #(pkgs.qgis.override { extraPythonPackages = (ps: [
66 # ps.pyqt5_with_qtwebkit
67 #]); })
68 #pkgs.libva-utils
69 pkgs.otpclient
70 pkgs.pandoc
71 pkgs.pdf2djvu
72 #pkgs.ristretto
73 pkgs.xfce.mousepad
74 #pkgs.mate.pluma
75 pkgs.wxmaxima
76 pkgs.espeak-ng
77 pkgs.iodine
78 #pkgs.qsynth
79 ];
80
81 /* Cannot be automounted
82 systemd.user.mounts = {
83 mnt-aubergine = {
84 Unit = {
85 Wants = [
86 "network-online.target"
87 "wireguard-wg-intra.target"
88 ];
89 After = [
90 "network-online.target"
91 "wireguard-wg-intra.target"
92 ];
93 };
94 Install = {
95 WantedBy = ["default.target"];
96 };
97 Mount = {
98 What = "julm@aubergine.sp:/";
99 Where = "/mnt/aubergine";
100 Type = "fuse.sshfs";
101 Options = lib.concatStringsSep "," [
102 "user"
103 "uid=julm"
104 "gid=users"
105 "allow_other"
106 "exec" # Override "user"'s noexec
107 "noatime"
108 "nosuid"
109 "noauto"
110 "dir_cache=no"
111 #"reconnect"
112 "x-gvfs-hide"
113 # Does not work for user mounts
114 #"x-systemd.automount"
115 "IdentityFile=/home/julm/.ssh/id_ed25519"
116 #"Compression=yes" # YMMV
117 # Disconnect approximately 2*15=30 seconds after a network failure
118 "ServerAliveCountMax=1"
119 "ServerAliveInterval=15"
120 ];
121 };
122 };
123 };
124 */
125 /*
126 Automounting does not work without root privileges
127 systemd.user.automounts = {
128 mnt-aubergine = {
129 Install = {
130 WantedBy = ["user.target"];
131 };
132 Unit = {
133 };
134 Automount = {
135 Where = "/mnt/aubergine";
136 TimeoutIdleSec = "5 min";
137 };
138 };
139 };
140 */
141 }