]> Git — Sourcephile - julm/julm-nix.git/blob - hosts/patate.nix
nix: cleaner fileset
[julm/julm-nix.git] / hosts / patate.nix
1 { config, pkgs, lib, ... }:
2 {
3 imports = [
4 ../nixos/profiles/graphical.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/laptop.nix
7 ../nixos/profiles/printing.nix
8 patate/backup.nix
9 patate/hardware.nix
10 patate/nebula.nix
11 patate/networking.nix
12 ];
13
14 # Lower kernel's security for better performances
15 security.kernel.mitigations = "off";
16
17 home-manager.users.sevy = {
18 imports = [ ../homes/sevy.nix ];
19 };
20 users.users.sevy = {
21 isNormalUser = true;
22 uid = 1000;
23 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
24 # which is already world readable.
25 hashedPassword = lib.readFile patate/users/sevy/login/hashedPassword.clear;
26 extraGroups = [
27 "adbusers"
28 config.services.davfs2.davGroup
29 "lp"
30 "networkmanager"
31 "scanner"
32 "systemd-journal"
33 "tor"
34 "vboxusers"
35 "video"
36 "wheel"
37 ];
38 };
39
40 nix = {
41 settings = {
42 substituters = [
43 #"ssh://nix-ssh@losurdo.wg?priority=30"
44 #"ssh://nix-ssh@oignon.wg?priority=10"
45 ];
46 trusted-public-keys = map lib.readFile [
47 ../users/root/nix/losurdo.pub
48 ../users/root/nix/oignon.pub
49 ];
50 };
51 };
52
53 environment.systemPackages = [
54 pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
55 ];
56
57 services.xserver = {
58 desktopManager = {
59 mate.enable = true;
60 xfce.enable = true;
61 xterm.enable = false;
62 };
63 displayManager = {
64 defaultSession = "mate";
65 autoLogin = {
66 user = config.users.users.sevy.name;
67 };
68 };
69 };
70
71 virtualisation.virtualbox.host.enable = true;
72
73 # This value determines the NixOS release with which your system is to be
74 # compatible, in order to avoid breaking some software such as database
75 # servers. You should change this only after NixOS release notes say you should.
76 system.stateVersion = "20.03"; # Did you read the comment?
77 }