]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/options.nix
nix: cleaner fileset
[julm/julm-nix.git] / nixos / options.nix
1 { lib, config, ... }:
2 with lib;
3 {
4 imports = [
5 modules/security/systemd-creds.nix
6 ];
7 options = {
8 install = {
9 target = mkOption {
10 type = types.str;
11 default = "\"\${NIXOS_TARGET:-root@${config.networking.hostName}.${config.networking.domain}}\"";
12 description = ''
13 SSH address to the target host's super-user.
14 '';
15 };
16 substituteOnDestination =
17 mkEnableOption "substitute-on-destination" // { default = true; };
18 };
19 };
20 }