]> Git — Sourcephile - julm/julm-nix.git/blob - nixos/profiles/builder.nix
xmonad: fix multiscreen support
[julm/julm-nix.git] / nixos / profiles / builder.nix
1 { lib, inputs, ... }:
2 {
3 nix.settings.experimental-features = [ "nix-command" "flakes" "repl-flake" ];
4 #nix.registry.self.flake = inputs.self;
5 nix.nixPath = [
6 "nixpkgs=${inputs.nixpkgs}"
7 ];
8
9 systemd.services.nix-daemon.serviceConfig = {
10 CPUSchedulingPolicy = lib.mkForce "batch";
11 IOSchedulingClass = lib.mkForce "best-effort";
12 # 0: high priority, 7: low priority
13 IOSchedulingPriority = lib.mkForce 4;
14 Nice = 0;
15 };
16
17 systemd.services.nix-gc.serviceConfig = {
18 CPUSchedulingPolicy = "batch";
19 IOSchedulingClass = "best-effort";
20 IOSchedulingPriority = 7;
21 Nice = 5;
22 };
23
24 systemd.sleep.extraConfig = ''
25 AllowSuspend=no
26 AllowHibernation=no
27 '';
28 }