5 "https://nix-community.cachix.org"
7 extra-trusted-public-keys = [
8 "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
14 doom-emacs.flake = false;
15 doom-emacs.url = "github:hlissner/doom-emacs";
16 home-manager.inputs.nixpkgs.follows = "nixpkgs";
17 home-manager.url = "github:nix-community/home-manager/release-24.05";
18 nix-formatter-pack.inputs.nixpkgs.follows = "nixpkgs";
19 nix-formatter-pack.url = "github:Gerschtli/nix-formatter-pack";
20 nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
21 git-hooks.inputs.nixpkgs.follows = "nixpkgs";
22 git-hooks.inputs.nixpkgs-stable.follows = "nixpkgs";
23 git-hooks.url = "github:cachix/git-hooks.nix";
28 remoteNixpkgsPatches = import nixpkgs/patches.nix;
29 localNixpkgsPatches = [
31 originPkgs = inputs.nixpkgs.legacyPackages."x86_64-linux";
32 nixpkgsPath = originPkgs.applyPatches {
33 name = "nixpkgs-patched";
34 src = inputs.nixpkgs.outPath;
35 patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
37 patch=$(printf '%s\n' ${builtins.concatStringsSep " "
38 (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)} |
39 sort | sha256sum | cut -c -7)
40 echo "-patch-$patch" >.version-suffix
43 profile = "/nix/var/nix/profiles/system";
44 inherit (inputs.nixpkgs) lib;
46 import nixpkgs/overlays.nix ++ [
48 #nixosSystem = lib.nixosSystem;
49 nixosSystem = import (nixpkgsPath + "/nixos/lib/eval-config.nix");
50 forAllSystems = f: lib.genAttrs lib.systems.flakeExposed (system: f rec {
52 #pkgs = inputs.nixpkgs.legacyPackages.${system};
53 pkgs = import nixpkgsPath {
55 overlays = overlays system;
58 self = with lib.fileset; toSource {
61 let exts = [ "clear" "conf" "cred" "crt" "css" "el" "hs" "json" "nix" "patch" "pem" "pub" "sh" "theme" "vim" ]; in
63 (fileFilter (file: lib.any file.hasExt exts) ./home-manager)
64 (fileFilter (file: lib.any file.hasExt exts) ./homes)
65 (fileFilter (file: lib.any file.hasExt exts) ./hosts)
66 (fileFilter (file: lib.any file.hasExt exts) ./nixos)
67 (fileFilter (file: lib.any file.hasExt exts) ./nixpkgs)
68 (fileFilter (file: lib.any file.hasExt exts) ./share)
69 (fileFilter (file: lib.any file.hasExt exts) ./users)
75 # nix -L build .#hello
76 packages = forAllSystems ({ pkgs, ... }: pkgs);
78 # nix -L build .#nixosConfigurations.oignon.config.system.build.toplevel
79 # nix -L build .#nixosConfigurations.oignon.config.boot.kernelPackages.kernel.configfile
80 # nix -L build .#nixosConfigurations.oignon.pkgs.hello
81 # nix eval --raw .#nixosConfigurations.oignon.config.networking.nftables.ruleset
82 nixosConfigurations = lib.genAttrs
83 (builtins.attrNames (lib.filterAttrs (_n: v: v == "directory") (builtins.readDir (self + "/hosts"))))
84 (hostName: nixosSystem {
87 # Required to avoid infinite recursion
88 # when `inputs` is used in `imports`.
93 (import (self + "/hosts/${hostName}.nix"))
97 hosts = nixosConfigurations;
98 host = nixosConfigurations.${hostName}._module.args;
100 nixpkgs.overlays = overlays config.nixpkgs.hostPlatform.system;
101 nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
111 inputs.home-manager.nixosModules.home-manager
113 home-manager.useGlobalPkgs = true;
114 home-manager.useUserPackages = true;
115 home-manager.verbose = true;
116 home-manager.backupFileExtension = null;
117 home-manager.extraSpecialArgs = {
118 inherit hostName inputs;
124 # nix -L develop or direnv allow
125 devShells = forAllSystems ({ pkgs, system, ... }:
127 default = pkgs.callPackage (self + "/shell.nix")
129 inherit pkgs inputs system nixpkgsPath;
130 inherit (checks.${system}.git-hooks-check) shellHook;
135 # nix -L run .#oignon.switch
136 apps = forAllSystems ({ pkgs, system, ... }:
139 (hostName: { config, ... }:
141 inherit (config.system) build;
142 scriptApp = scriptName: ps: script: {
144 program = (pkgs.writeShellScript "${hostName}-${scriptName}" ''
145 export PATH="${lib.makeBinPath ([ pkgs.coreutils ] ++ ps)}:$PATH"
152 # Example: nix run .#aubergine.switch
153 "switch" = scriptApp "switch" [ ] ''
156 chmod -R g-rwx,o-rwx **/*.gpg
157 trap 'git reset **/*.gpg' EXIT
158 git rm -rf --cached --ignore-unmatch **/*.gpg # prevent copying to /nix/store
160 nix-store --add-root hosts/${hostName}.nixpkgs --indirect --realise ${nixpkgsPath}
161 nix-store --add-root hosts/${hostName}.root --indirect --realise ${build.toplevel}
163 nix copy --to "ssh://${config.install.target}?''${targetStore-}"${lib.optionalString config.install.substituteOnDestination " --substitute-on-destination"} ${build.toplevel}
165 if ssh ${config.install.target} set -x ';' \
166 systemctl reset-failed nixos-fallback '2>/dev/null' ';' \
167 test "''${NO_NIXOS_FALLBACK:+set}" '||' \
168 systemd-run -u nixos-fallback --description=nixos-fallback /bin/sh -xc '''\'''
169 PATH=${with pkgs; lib.makeBinPath [ coreutils nix systemd ]}
171 ${profile}/bin/switch-to-configuration switch
174 ${build.toplevel}/bin/switch-to-configuration test
176 ssh ${config.install.target} -o ControlPath=none set -x ';' \
177 systemctl stop nixos-fallback.service ';' \
178 nix-env --profile ${profile} --set '${build.toplevel}' ';' \
179 ${build.toplevel}/bin/switch-to-configuration boot '&&' \
180 nix-env --delete-generations 7d --profile ${profile}
183 echo WARNING: switch-to-configuration was not registered at boot
185 ssh ${config.install.target} -o ControlPath=none set -x ';' \
186 systemctl stop nixos-fallback.service
191 nixosConfigurations);
194 checks = forAllSystems (args: with args; {
195 git-hooks-check = inputs.git-hooks.lib.${system}.run {
198 nixpkgs-fmt.enable = true;
204 formatter = forAllSystems ({ pkgs, ... }:
205 inputs.nix-formatter-pack.lib.mkFormatter {
209 deadnix.enable = true;
210 nixpkgs-fmt.enable = true;
211 statix.enable = true;