1 { pkgs, lib, hostName, ... }:
4 ../../nixos/profiles/hardware/apu6b4.nix
5 ../../nixos/profiles/hardware/ME909u-521.nix
6 ../../nixos/profiles/serial.nix
7 ../../nixos/profiles/zfs.nix
8 ../../nixos/profiles/zramSwap.nix
9 ../../nixos/profiles/pipewire.nix
12 # Setting the machine-id avoids to reencrypt all credentials
13 # when reinstalling NixOS on a new drive.
14 # Manually generated with : uuidgen | tr -d -
15 environment.etc.machine-id.source = ./machine-id.clear;
17 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
18 # You should try to make this id unique among your hosts.
19 # Manually generated with : uuidgen | head -c8
20 networking.hostId = "408a404a";
24 canTouchEfiVariables = true;
25 efiSysMountPoint = "/boot/efi";
31 #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
32 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
33 "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
35 configurationLimit = 9;
39 #enableCryptodisk = true;
42 boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
43 boot.extraModulePackages = [
44 #config.boot.kernelPackages.exfat-nofuse
46 boot.zfs.requestEncryptionCredentials = [ hostName ];
48 hardware.enableRedistributableFirmware = true;
50 powerManagement.powertop.enable = true;
52 #services.fprintd.enable = true;
56 device = "${hostName}/root";
61 device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
64 fileSystems."/boot/efi" =
66 device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
71 device = "${hostName}/nix";
76 device = "${hostName}/var";
81 device = "${hostName}/home";
87 device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
90 cipher = "aes-xts-plain64";
91 source = "/dev/urandom";