5 "https://nix-community.cachix.org"
7 extra-trusted-public-keys = [
8 "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
14 doom-emacs.flake = false;
15 doom-emacs.url = "github:hlissner/doom-emacs";
16 home-manager.inputs.nixpkgs.follows = "nixpkgs";
17 home-manager.url = "github:nix-community/home-manager/release-23.11";
18 nix-formatter-pack.inputs.nixpkgs.follows = "nixpkgs";
19 nix-formatter-pack.url = "github:Gerschtli/nix-formatter-pack";
20 nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.11";
21 pre-commit-hooks.inputs.nixpkgs.follows = "nixpkgs";
22 pre-commit-hooks.inputs.nixpkgs-stable.follows = "nixpkgs";
23 pre-commit-hooks.url = "github:cachix/pre-commit-hooks.nix";
28 remoteNixpkgsPatches = import nixpkgs/patches.nix;
29 localNixpkgsPatches = [
31 originPkgs = inputs.nixpkgs.legacyPackages."x86_64-linux";
32 nixpkgsPath = originPkgs.applyPatches {
33 name = "nixpkgs-patched";
34 src = inputs.nixpkgs.outPath;
35 patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
37 patch=$(printf '%s\n' ${builtins.concatStringsSep " "
38 (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)} |
39 sort | sha256sum | cut -c -7)
40 echo "-patch-$patch" >.version-suffix
43 profile = "/nix/var/nix/profiles/system";
44 inherit (inputs.nixpkgs) lib;
45 #nixosSystem = lib.nixosSystem;
46 nixosSystem = import (nixpkgsPath + "/nixos/lib/eval-config.nix");
47 forAllSystems = f: lib.genAttrs lib.systems.flakeExposed (system: f rec {
49 #pkgs = inputs.nixpkgs.legacyPackages.${system};
50 pkgs = import nixpkgsPath {
52 overlays = import nixpkgs/overlays.nix;
55 self = with lib.fileset; toSource {
58 let exts = [ "clear" "conf" "cred" "crt" "css" "el" "hs" "json" "nix" "patch" "pem" "pub" "sh" "theme" "vim" ]; in
60 (fileFilter (file: lib.any file.hasExt exts) ./home-manager)
61 (fileFilter (file: lib.any file.hasExt exts) ./homes)
62 (fileFilter (file: lib.any file.hasExt exts) ./hosts)
63 (fileFilter (file: lib.any file.hasExt exts) ./nixos)
64 (fileFilter (file: lib.any file.hasExt exts) ./nixpkgs)
65 (fileFilter (file: lib.any file.hasExt exts) ./share)
66 (fileFilter (file: lib.any file.hasExt exts) ./users)
72 # nix -L build .#hello
73 packages = forAllSystems ({ pkgs, ... }: pkgs);
75 # nix -L build .#nixosConfigurations.oignon.config.system.build.toplevel
76 # nix -L build .#nixosConfigurations.oignon.config.boot.kernelPackages.kernel.configfile
77 # nix -L build .#nixosConfigurations.oignon.pkgs.hello
78 # nix eval --raw .#nixosConfigurations.oignon.config.networking.nftables.ruleset
79 nixosConfigurations = lib.genAttrs
80 (builtins.attrNames (lib.filterAttrs (_n: v: v == "directory") (builtins.readDir (self + "/hosts"))))
81 (hostName: nixosSystem {
84 # Required to avoid infinite recursion
85 # when `inputs` is used in `imports`.
90 (import (self + "/hosts/${hostName}.nix"))
94 hosts = nixosConfigurations;
95 host = nixosConfigurations.${hostName}._module.args;
97 nixpkgs.overlays = import (self + "/nixpkgs/overlays.nix");
98 nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
108 inputs.home-manager.nixosModules.home-manager
110 home-manager.useGlobalPkgs = true;
111 home-manager.useUserPackages = true;
112 home-manager.verbose = true;
113 home-manager.backupFileExtension = null;
114 home-manager.extraSpecialArgs = {
115 inherit hostName inputs;
121 # nix -L develop or direnv allow
122 devShells = forAllSystems ({ pkgs, system, ... }:
124 default = pkgs.callPackage (self + "/shell.nix")
126 inherit pkgs inputs system nixpkgsPath;
127 inherit (checks.${system}.pre-commit-check) shellHook;
132 # nix -L run .#oignon.switch
133 apps = forAllSystems ({ pkgs, system, ... }:
136 (hostName: { config, ... }:
138 inherit (config.system) build;
139 scriptApp = scriptName: ps: script: {
141 program = (pkgs.writeShellScript "${hostName}-${scriptName}" ''
142 export PATH="${lib.makeBinPath ([ pkgs.coreutils ] ++ ps)}:$PATH"
149 # Example: nix run .#aubergine.switch
150 "switch" = scriptApp "switch" [ ] ''
153 chmod -R g-rwx,o-rwx **/*.gpg
154 trap 'git reset **/*.gpg' EXIT
155 git rm -rf --cached --ignore-unmatch **/*.gpg # prevent copying to /nix/store
157 nix-store --add-root hosts/${hostName}.nixpkgs --indirect --realise ${nixpkgsPath}
158 nix-store --add-root hosts/${hostName}.root --indirect --realise ${build.toplevel}
160 nix copy --to "ssh://${config.install.target}?''${targetStore-}"${lib.optionalString config.install.substituteOnDestination " --substitute-on-destination"} ${build.toplevel}
162 if ssh ${config.install.target} set -x ';' \
163 systemctl reset-failed nixos-fallback '2>/dev/null' ';' \
164 test "''${NO_NIXOS_FALLBACK:+set}" '||' \
165 systemd-run -u nixos-fallback --description=nixos-fallback /bin/sh -xc '''\'''
166 PATH=${with pkgs; lib.makeBinPath [ coreutils nix systemd ]}
168 ${profile}/bin/switch-to-configuration switch
171 ${build.toplevel}/bin/switch-to-configuration test
173 ssh ${config.install.target} -o ControlPath=none set -x ';' \
174 systemctl stop nixos-fallback.service ';' \
175 nix-env --profile ${profile} --set '${build.toplevel}' ';' \
176 ${build.toplevel}/bin/switch-to-configuration boot '&&' \
177 nix-env --delete-generations 7d --profile ${profile}
180 echo WARNING: switch-to-configuration was not registered at boot
182 ssh ${config.install.target} -o ControlPath=none set -x ';' \
183 systemctl stop nixos-fallback.service
188 nixosConfigurations);
191 checks = forAllSystems (args: with args; {
192 pre-commit-check = inputs.pre-commit-hooks.lib.${system}.run {
195 nixpkgs-fmt.enable = true;
201 formatter = forAllSystems ({ pkgs, ... }:
202 inputs.nix-formatter-pack.lib.mkFormatter {
206 deadnix.enable = true;
207 nixpkgs-fmt.enable = true;
208 statix.enable = true;